Items and Links can be createde in Paper UI but not in Config

I run my openHAB on a raspberry 3B+. I use Raspberry OS (I have also pihole running on it. pi hole does not run on openhabian).

Everything is set up, I created a simple sitemap, and made a binding with my Fritz Box, where a DECT Thermostat is connected. I added the thing with the Paper UI.

Now I am just palying around to get to know the platfrom. But now my problem: if I create an item with the Paper UI and integrate this into the sitemap, everything runs smoothly. But if I create an item with Visual Code, the item cannot be found with the Paper UI and in the sitemap, the values are not shown.

 //Item created and copied from PaperUI => works
Number HeizungArbeitszimmer_CurrentTemperature "Heizung Arbeitszimmer" <heating> (Arbeitszimmer) {channel=avmfritz:Comet_DECT:192_168_178_21:133570399248:temperature}
//Test item created with Visual Code (with the plugin and connected to the Raspberry) => No link or item in PaperUI. Entry shown in Basic UI, but no value
Number Temperature_ComfortTemp "Comfort temperature" {channel=avmfritz:Comet_DECT:192_168_178_21:133570399248:comfort_temp}

I checekd the .items file on the raspberry and indeed has the same content as the Visual Code file.
Below the image from the Basic UI.
2020-11-08 09_21_52-My Sitemap

As soon as I create the item with the name “Temperature_ComfortTemp”

Number Temperature_ComfortTemp "Comfort temperature"

in the Paper UI, everything works.

Thanks so much for your help

Try changing:




Ensure you do not try to duplicate the Item name between PaperUI and configuration files - this won’t work as you expect!

Your openhab.log probably offers clues.
When the file watcher notices a new/updated xxx.items file in the correct folder, it will announce it’s going to load it there.
If there’s something wrong with your syntax, it usually, says so.
If a UI tries to fetch an Item, that doesn’t exist, there’ll be a message about that.

1 Like

thanks for the response. did not change anything. It would currentyl be the only item for this channel.

The log is full of
2020-11-08 07:59:44.849 [ERROR] [ui.internal.items.ItemUIRegistryImpl] - Cannot retrieve item ‘Temperature_ComfortTemp’ for widget org.eclipse.smarthome.model.sitemap.sitemap.Setpoint

The same is true for the other items. I also cleared the chache.

That means the Item doesn’t exist as far as openHAB is concerned. Is this one you tried to create via files? When you save the items file, do you get confirmation in the logs that the Items have been processed?

That doesn’t matter - you can have more than one Item attached to the same Channel. However, you shouldn’t make two identical Items, one via files, and one via PaperUI, because that won’t work. Not saying you have done that, just an FYI.

okay. wired. I moved the itmes that casued problems in an own .items file and suddenly it works
I hope I don`t have to do this with all things
otherwise there might be a lot of items files

You probably overlooked error messages relating to syntax in your file, or you got the file extension wrong. There won’t be magic involved.

not really. The first 2 items worked. The second set of three icons not. Copying the second set in a new items-file and leaving the first two in the orignal file solved the problem. I did not change the syntax or the file extension. Anyway. Thanks for your help

But since I am a absolute beginner, I admit magic is just stuff we don`t fully understand;)

There are two potential sources of the problem.

  1. The syntax in your .items file is incorrect in which case you should see errors in openhab.log when the file is loaded.

  2. You’ve recently cleared the cache. There is a known problem where Items disappear after clearning the cache. You should wait for OH to come up, then reboot. That should clear things up.

Note, hafniumzinc’s suggestion is good as well. The quotes around the channel ID is required.

The fact that copying the Items to a new file indicates that 2 was probably the original problem.

I also think 2. was the problem. I never had problems with my items again.

This stuff is addictive. There should be a warning on the openHAB site.

Thanks for the help guys