Items as created via .items file do not show up in paper UI

  • Platform information:
    • Hardware: Rasbperry 4b
    • OS: Linux
    • Java Runtime Environment: openjdk version “11.0.12” 2021-07-20 LTS
    • openHAB version: 3.3

Hello, as our small guesthose is now populated more and more with devices to get integrated into Openhab I started to get myself comfortable with using .items file to instead of using PaperUI.
I just wanted to create a couple of airconditioning things/item from the Melcloud binding (Mitsubishi). While this has worked quite well with PaperUI, I have a specific problem when using the file approach: The points show up well in the model tree when with PaperUI created, but are missing when created via items file. They are however there when I click in the parent item (which is the HVAC device itself).

This sounds a little weird, so some pictures to help:

Created via PaperUI, points show up in the tree:


Created via items file:


Opening the group item in the modeltree in the version with the file, all items are however there:

And here is the respective part of the items file:


Switch				CLIMA_MASIA_PB_COCINA_power				<switch>		(CLIMA_MASIA_PB_COCINA) { channel="melcloud:acdevice:myaccount:CLIMA_MASIA_PB_COCINA:power" }
String				CLIMA_MASIA_PB_COCINA_operationMode		<settings>		(CLIMA_MASIA_PB_COCINA) { channel="melcloud:acdevice:myaccount:CLIMA_MASIA_PB_COCINA:operationMode" }
Number:Temperature	CLIMA_MASIA_PB_COCINA_setTemperature	<temperature>	(CLIMA_MASIA_PB_COCINA) { channel="melcloud:acdevice:myaccount:CLIMA_MASIA_PB_COCINA:setTemperature" }
String				CLIMA_MASIA_PB_COCINA_fanSpeed			<flow>			(CLIMA_MASIA_PB_COCINA) { channel="melcloud:acdevice:myaccount:CLIMA_MASIA_PB_COCINA:fanSpeed" }
Number:Temperature	CLIMA_MASIA_PB_COCINA_roomTemperature	<temperature>	(CLIMA_MASIA_PB_COCINA) { channel="melcloud:acdevice:myaccount:CLIMA_MASIA_PB_COCINA:roomTemperature" }
DateTime			CLIMA_MASIA_PB_COCINA_lastCommunication	<time>			(CLIMA_MASIA_PB_COCINA) { channel="melcloud:acdevice:myaccount:CLIMA_MASIA_PB_COCINA:lastCommunication" }
Switch				CLIMA_MASIA_PB_COCINA_offline							(CLIMA_MASIA_PB_COCINA) { channel="melcloud:acdevice:myaccount:CLIMA_MASIA_PB_COCINA:offline" }

If I check the individual points in both versions the only difference I note is that PaperUI created the equipment points with a “point” tag. Not sure if this makes a difference? I also tried to add a [“point”] tag at the point level, but for whatever reasons this results in an error (not sure why).


First of all, openHAB 3.x does not have PaperUI, this was the UI used in openHAB 2.x
In openHAB 3.x it is called MainUI.

What You descibe is normal, as your .items file(s) do(es) not contain any semantic tagging, therefore you will not see those Items in the model, unless you use the little tic box at the bottom.
Then you will see all items.

Ah okay. Never though about the name of the UI, thanks for correcting and yes - this little box solved the problem ,-)
Can you point me to where there is some explanation about “semantic tagging”, and also what this box exactly does? I just reread the items file documentation and noticed I had an wrong sequence in the definition of attributes of my equipment points, just added a “point” tag and they appeared without the box. Still not sure what the background behind this is for the MainUI, but it works now for me ,-)

Thanks for helping!

Take a look here