Items failing to update

Openhab 2.4.0M3
Homematic binding

Many (but not all) Homematic items are failing to update in both Classic and Basic UIs.
The log file confirms that (e.g. changes in temperature etc.) are being logged for the failed items and I’ve verified that the updates are being sent to
Can’t say for sure but I believe this may have started when I changed from stable to testing.

Tried reinstalling myopenhab binding (regenerating UUID etc.) and reinstalling rrd4J. without correcting the issue.

Also confirmed that updated items are available via the REST API.

Items from other bindings are being updated correctly. Doesn’t seem that it is a Homematic binding problem as updates are recorded in events.log.

Any idea what may be happening?


Does a reload of the sitemap in the browser show the latest values?

Are all of the Items that are failing to update using the same element on your sitemap (e.g. are they all Text or Switch, etc.)?

Hi Rich,

Thanks for helping out.

I’ve reloaded the sitemap from a backup without success and deleted and re-entered items within the sitemap without success. I’ve also created a new sitemap with just one of the failed items and it still doesn’t update.

Current list of sitemap commands that have failures.

Text - 22 of 40 not updating
Setpoint - 7 of 11 not updating
Switch - All the switches are updating

Each of failed items have a relevant log entry confirming a change of state.

Hope this helps


Are the Items that are not updating in sub Frames?

Do the Items that don’t update appear in more than one place on your sitemap?

Do they update in the phone apps?

Hi Rich, Thanks again for helping out.

Hopefully I’ve uploaded a pdf of the sitemap with entries bold and underlines if they are NOT updating. I’ve also added a brief description (in red) of the function of the entry. These are the results on Classic and Basic UIs.

Oddly the IOS app updates all the set points but the text entry failures match that of Classic UI.

Hope this helps because it’s confusing the hell out of me.


RoyHome.Sitemap.pdf (16.7 KB)

I think there is a known issue with setpoints in BasicUI and ClassicUI.

In the future it is way easier to deal with code if you paste it into your reply using code fences (How to use code fences) or if it won’t let you because you are too new to post something that big, use pastebin or github gists. A PDF is really hard to work with.

I don’t see any pattern with the sitemap definition for the ones that are not working. I don’t really have any other ideas. You can try to file an issue over at ESH (which is where Basic UI is implemented) but without more information that will let the developers reproduce the error I’m not sure anyone will be able to fix it. It is very odd behavior.

Hi Rich,

Thanks for the feed back. Sounds like the next step may be a complete rebuild before I forward it to ESH. It seems so random that I’m assuming it is some form of corruption which should be resolved by a rpi3 rebuild.