Items for FIBARO Roller Shutter 3

Tags: #<Tag:0x00007fc3f7e7ef38>

Hi again. Tried the openHAB SNAPSHOT last weekend and destroyed my whole system by doing that. Have now re-built. How can I get the zwave jar from the SNAPSHOT?

Sorry for asking these kind of questions. Still trying to find my way in openHAB. Currently using homee with a number of FIBARO Roller Shutter (2 and 3), Single Switch 2, Devolo and Aeotec plugs and Strips Guard. Also using hue, Alexa, myStrom plugs, Netatmo, Logitech Harmony hub and a bunch of HomeKit devices

See below https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/binding/
Note this combo might work or not.

Danke Markus. Ich werde das dann ausprobieren.

Thank you Markus.

Sorry for bothering you again. Is is correct to do it like this:

  1. Install openHABian (I will install the Milestone Release)
  2. Install Z-Wave Binding
  3. Download the *.jar that you provided into the add-ons folder

Or do I skip step 2 and just copy the *.jar in the add-ons folder?

Anything else to consider?

Skip step 2.
And if you already run openHABian there’s no need to reinstall it. Just select the proper menu option to get openHAB installed.

Hello again,

I have setup my openHAB installation completely from scratch now. All works fine. The Roller Shutter 2 (FIBARO) are recognized as blind_control, but the Roller Shutter 3 (FIBARO) are still recognized as switch_dimmer.

I am using the Milestone release. Not the SNAPSHOT. However, for a while I had copied the SNAPSHOT into add-ons, but that did not make a change at all. So I removed it again.

Any hint? And thanks in advance.

The change from switch_dimmer to blinds_control is not in the milestone, you need the snapshot.
After installation of the snapshot you need to delete the Thing and readd it to pick up the database changes.

Sorry for asking stupid questions, I am still not so familiar with openHAB.

Where/how to delete and add? You do not mean to exclude and include again. Correct?

And I need to copy this file https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/binding/org.openhab.binding.zwave/1.14.0-SNAPSHOT/ into the addons folder, no need to uninstall the Z-Wave binding. Correct

PaperUI or HABmin.


Most right icon.

No, don’t exclude and reinclude.

Thank you.

It will appear in the inbox again after deletion?

No, not you but the device :grinning:

Hi again,

I have copied the SNAPSHOT into the add ons folder. However, I had previously installed the Z-Wave binding. Deleted one RS3 according to your instructions. But when I added it again, I had the same result as before. See screenshot:

Do I need to uninstall the Z-Wave binding to make it work?
In that case, what do I need to pay attention to?

Thanks

Yes.
Uninstall the binding from PaperUI, drop the snapshot in your addons folder, make sure through Karaf the new zwave binding is active, delete the Thing, readd the Thing.

How do I do that?

bundle:list | grep -i zwave

Done. But now I get this:

and this:

I checked the karat and the binding is active

bundle:restart xxx where xxx is the zwave binding number

That is 241 in my example? Or something else?

Result is:

I rebooted in-between

Yes, but you have a version 1 zwave binding installed, you need a version 2 binding:

https://ci.openhab.org/job/openHAB2-Bundles/org.openhab.addons.bundles$org.openhab.binding.zwave/

Also make sure you are reading:


:+1:

Thank you very much for your support. Now it is working.

1 Like