[SOLVED] Items for FIBARO Roller Shutter 3

Tags: #<Tag:0x00007f61736ea808>

FIBARO Roller Shutter 3

When I included the RS3, I got a list of items, none of those were of type rollershutter. The items to control the movement of the RS3 were of type switch_dimmer. Is this correct?

No. This was changed to blinds_control a while ago:
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/983
If you are on a stable openHAB zwave binding you need to upgrade your zwave binding to the latest snapshot.

Does the same apply for the FIBARO Roller Shutter 2?

So I have to switch to the SNAPSHOT, not the MILESTONE release?

When will the next milestone release take place?

Yes it’s blinds_control there, too.

Depends on when the device was added. Try the milestone.

There’s no date yet.

Tried the MILESTONE last weekend. That’s why I am asking.

So that means, that I have to exclude and after that include the device again to get the mapping between items and channels correct or is there any other way to do that?

After upgrading just delete the Thing and readd it. No need for ex-/inclusion.

Please tell us all by yourself next time.

If you have a problem running snapshot you can install milestone and override the zwave binding by the one from the snapshot, i.e. put the snapshot zwave jar into the addons folder.

Thank you both

Hi again. Tried the openHAB SNAPSHOT last weekend and destroyed my whole system by doing that. Have now re-built. How can I get the zwave jar from the SNAPSHOT?

Sorry for asking these kind of questions. Still trying to find my way in openHAB. Currently using homee with a number of FIBARO Roller Shutter (2 and 3), Single Switch 2, Devolo and Aeotec plugs and Strips Guard. Also using hue, Alexa, myStrom plugs, Netatmo, Logitech Harmony hub and a bunch of HomeKit devices

See below https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/binding/
Note this combo might work or not.

Danke Markus. Ich werde das dann ausprobieren.

Thank you Markus.

Sorry for bothering you again. Is is correct to do it like this:

  1. Install openHABian (I will install the Milestone Release)
  2. Install Z-Wave Binding
  3. Download the *.jar that you provided into the add-ons folder

Or do I skip step 2 and just copy the *.jar in the add-ons folder?

Anything else to consider?

Skip step 2.
And if you already run openHABian there’s no need to reinstall it. Just select the proper menu option to get openHAB installed.

Hello again,

I have setup my openHAB installation completely from scratch now. All works fine. The Roller Shutter 2 (FIBARO) are recognized as blind_control, but the Roller Shutter 3 (FIBARO) are still recognized as switch_dimmer.

I am using the Milestone release. Not the SNAPSHOT. However, for a while I had copied the SNAPSHOT into add-ons, but that did not make a change at all. So I removed it again.

Any hint? And thanks in advance.

The change from switch_dimmer to blinds_control is not in the milestone, you need the snapshot.
After installation of the snapshot you need to delete the Thing and readd it to pick up the database changes.

Sorry for asking stupid questions, I am still not so familiar with openHAB.

Where/how to delete and add? You do not mean to exclude and include again. Correct?

And I need to copy this file https://openhab.jfrog.io/openhab/libs-pullrequest-local/org/openhab/binding/org.openhab.binding.zwave/1.14.0-SNAPSHOT/ into the addons folder, no need to uninstall the Z-Wave binding. Correct

PaperUI or HABmin.


Most right icon.

No, don’t exclude and reinclude.

Thank you.

It will appear in the inbox again after deletion?

No, not you but the device :grinning:

Hi again,

I have copied the SNAPSHOT into the add ons folder. However, I had previously installed the Z-Wave binding. Deleted one RS3 according to your instructions. But when I added it again, I had the same result as before. See screenshot:

Do I need to uninstall the Z-Wave binding to make it work?
In that case, what do I need to pay attention to?

Thanks