Items.metadata json file bug?

I’m running Openhabian 2.5.5 on a raspberry pi 3+ and was running into strange issues with some Zwave items I tried to remove from paper UI since I wanted to declare them in an Items file instead in order to add ga= metadata for google home. After removing the link in the Items and then removing the item itself in PaperUI, although item file had them both declared, none of the Items were visible anywhere. To investigate the issue, I scanned through the items json db files to indeed confirm both items and link were removed -but found reference for both items into the “org.eclipse.smarthome.core.items.Metadata.json” file under HUEEMU.
I had indeed shortly enabled HUE emulation and then removed it, but apparently this resulted in all items to get a HUEEMU entry in the items.metadata jsonDB file.
After taking a backup of the items.metadata jsonDB file, I deleted all occurrences of the HUEEMU references and guess what? Both item file declared items now worked fine!
I think this should be considered as an Openhab bug. Either, old PaperUI items with remaining metadata in json db, should be ignored by paper UI, or metadata should be automatically deleted from item.metadata json to avoid this strange behavior.

Anyway, if you run into similar issues, a look into item.metadata json could save a lot of time to resolve issues.



Maybe related:

If you deem it a bug, and I’d agree this is not desirable behavior, please file an issue on openhab-core. See How to file an Issue.

Hi Rich. Thanks for the advice. I’ll file the issue tomorrow.

Just filed the issue on openhab-core github. Since this is my first bug report, please let me know whether I did it right. Txs