Items Missing from Google Home

A couple weeks ago, Google Home lost it’s connection to any of my linked lights. All these items were set up with OH3 via the UI and metadata.

Looking in the UI, the metadata seems to have vanished (no idea) so I added it back in but still nothing. I have tried re-linking through google assistant but it’s still not seeing any items. Here’s where I’m at:

  • myopenhab is online and shows Google as an authorized application
  • openHAB seems to be registered through Google as I see an “unlink” button on this page
  • I have UI created items with metadata (Dimmer items with GA class “Light”)
  • I created a debug.items file with the suggested “Switch TestLight “Test Light” { ga=“Switch” }”

None of these items show up through google home. Any assistance would be appreciated.

How are you refreshing Google’s configuration? You either need to remove and re-add the link, or ask Google Assistant to refresh your devices with “sync my devices”. In the Android app, you can do a long pull down to trigger a sync, too.

It won’t magically show up. Google refreshes state of the items it knows about but doesn’t poll for new devices.

Found the issue.

In the OH3 UI, under “Settings → Other Services → openHAB Cloud → Mode” I had it set to “Notifications” switching to “Notifications and Remote Access” fixed the issue.