Jasco ZWave Smart Dimmer Toggle QuickFit (zw4009) - The device is not in the database

I recently bought a new release from Jasco in the dimmer toggle version of their zwave line (zw4009). I was in 2.4, upgraded to 2.5.2 but I’m still getting ‘The device is not in the database’. Does anyone know when this device will be added to the zwave binding? I read someone else upgraded to the unstable 2.5.3 and that supposedly fixed it but when I follow the instructions on https://www.openhab.org/download/ it says that the version I have is the latest version. Also, 2.5.2 is causing my zwave binding to restart every 30 seconds or so. The restart issue sounds like someone else who had this problem (Z-Wave Binding: UNINITIALIZED - HANDLER_MISSING_ERROR) but I don’t have any mqtt services which seemed to be the root of their problem.

Any invalid addon causes all addons to reload every minute trying to load the invalid one. A common culprit is restdocs since its location moved from misc to ui.
Look in the addons.config file down in the userdata tree. Stop OH before changing it though since it usually maintains it.

Thanks. I ended up restoring my pi from a backup to a prior version of Openhab. If I eventually upgrade and openhab is still unstable I’ll give this a try.

It might be worh posting your addons.config from your userdata tree here. 2.4 just ignored invalid addons. I think the newer Karaf changed the behaviour in 2.5.x.

The core is frozen and only addons are updated now as the devs work on OH3.

Add-on file attached

addons.txt (2.2 KB)

That is addons.cfg from the config folder, not addons.config created bu openHAB in the userdata tree. (I forget which folder in there.)

Not sure where to find that. I tried to figure that out, looked at https://www.openhab.org/docs/configuration/addons.html, but that wasn’t helpful. Anyone have any suggestions on where I should look?

One common place would be in /var/lib/openhab2/config/org/openhab/addons.config but the path of userdata varies depending on the installation type.

I would never have found that on my own, thank you. Is the attached then what you are looking for.addons.txt (379 Bytes)

1 Like

Thank you.
Definitely uninstall restdocs before upgrading and then reinstall. It moved within OH from misc to ui Leaving it installed will cause all addons to reload every minute, trying to load the invalid one.
That is the only problem I see offhand.