Java Heap Space problem on OH3

Hi everybody,
I moved to OH3 (rel. 3.2.0) in january; I started with a new clean installation.

After a few days I got my first crash due to “java.lang.OutOfMemoryError: Java heap space” and since then I’m getting this error every 5 days.

I first tried to disable all my DSL rules (as suggested in a similar post) and then I tried to stop all the bindings, but noting changed (with all bindings and rules off, I’m still getting the error every 6 or 7 days…).
I’m monitoring heap space with Openhab System Info binding and I can see heap used percentage growing day by day…

Next I’ll try to disable rrd4j persistence, then I’ve no other ideas…

Do you guys have any suggestion?



Do you use VS Code to manage your openHAB config, and do you leave it open continuously?

Hi @mhilbush , no, never used VS Code.


Oh well. It was worth a shot.

You disabled all your DSL rules, do you have any rules in other languages? Then you stop all the binding… and it is still crashing? What is still running?
No rules running, no bindings running and still crashing… something else is buggered up
What is hardware platform? What is host operating system? Details on set up please. Also, what else is running on the host?
Typically heap space gets consumed because of a memory leak in a buggy binding. If you have all bindings stopped and it still crashes, something bigger is broken

No, I don’t have any other rule running

Yes, I stopped all bindings added (only rrd4j persistence is running); it gets better, but after a few more days it still crashes…

Hardware is an Acer AspireONE with Debian 10 and OpenJDK v11; nothing else is running on the host, except Mosquitto for MQTT.

Attached there is an image with heap used percentage: when I stop OpenHab, it goes down (around 30/35 %).

Thanks for your reply

Are the DSL rules file based or created in the UI?
When you said you ‘disabled’ your DSL rules do you mean disable in the UI?
Sorry but the only thing I can think of is the installation didn’t work properly somehow and wipe it and try again. Back everything up first
I sorry things aren’t working for you, lots of other folks run the same version so we’d hear about it if something was this wrong. This type of issue overall is very rare.

Yes, rules were created in UI (and then disabled in UI) (btw I only have a few rules…).
Bindings were disabled from the console.

Thanks again for your replies, I’ll do a few more test with everything off, then I’ll go for a new fresh installation.


1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.