JDBC Persistence with SQLite not working in openHAB 1.8.0

I configured JDBC persistence for SQLite but it does not create any database or store any data. Openhab.log shows this output:

2016-01-29 12:18:23.381 [DEBUG] [o.p.j.i.JdbcPersistenceService] - JDBC::setItemRegistry
2016-01-29 12:18:23.384 [DEBUG] [o.p.j.i.JdbcPersistenceService] - JDBC::activate: persistence service activated
2016-01-29 12:18:23.386 [DEBUG] [o.p.j.i.JdbcPersistenceService] - JDBC::updateConfig
2016-01-29 12:18:23.389 [DEBUG] [p.j.internal.JdbcConfiguration] - JDBC::JdbcConfiguration
2016-01-29 12:18:23.391 [DEBUG] [p.j.internal.JdbcConfiguration] - JDBC::updateConfig: configuration.size = 8
2016-01-29 12:18:23.393 [DEBUG] [p.j.internal.JdbcConfiguration] - JDBC::updateConfig: url=jdbc:sqlite:./testSqlite.db
2016-01-29 12:18:23.395 [DEBUG] [p.j.internal.JdbcConfiguration] - JDBC::updateConfig: found serviceName = 'sqlite'
2016-01-29 12:18:23.396 [DEBUG] [p.j.internal.JdbcConfiguration] - JDBC::updateConfig: Init Data Access Object Class: 'org.openhab.persistence.jdbc.db.JdbcSqliteDAO'
2016-01-29 12:18:23.397 [DEBUG] [ersistence.jdbc.db.JdbcBaseDAO] - JDBC::initSqlTypes: Initialize the type array
2016-01-29 12:18:23.398 [DEBUG] [ersistence.jdbc.db.JdbcBaseDAO] - JDBC::initSqlQueries: 'JdbcSqliteDAO'
2016-01-29 12:18:23.398 [DEBUG] [o.o.p.jdbc.db.JdbcSqliteDAO   ] - JDBC::initSqlQueries: 'JdbcSqliteDAO'
2016-01-29 12:18:23.399 [DEBUG] [p.j.internal.JdbcConfiguration] - JDBC::updateConfig: dBDAO ClassName=org.openhab.persistence.jdbc.db.JdbcSqliteDAO
2016-01-29 12:18:23.400 [DEBUG] [p.j.internal.JdbcConfiguration] - JDBC::updateConfig:  user=test
2016-01-29 12:18:23.401 [DEBUG] [p.j.internal.JdbcConfiguration] - JDBC::updateConfig:  password=<masked> password.length=4
2016-01-29 12:18:23.402 [DEBUG] [p.j.internal.JdbcConfiguration] - JDBC::updateConfig: tableUseRealItemNames=true
2016-01-29 12:18:23.402 [DEBUG] [p.j.internal.JdbcConfiguration] - JDBC::updateConfig: enableLogTime false
2016-01-29 12:18:23.403 [WARN ] [p.j.internal.JdbcConfiguration] - JDBC::updateConfig: try to load JDBC-driverClass: 'org.sqlite.JDBC'
2016-01-29 12:18:23.404 [DEBUG] [p.j.internal.JdbcConfiguration] - JDBC::updateConfig: load JDBC-driverClass was successful: 'org.sqlite.JDBC'
2016-01-29 12:18:23.404 [DEBUG] [p.j.internal.JdbcConfiguration] - JDBC::updateConfig: configuration complete. service=jdbc
2016-01-29 12:18:23.405 [DEBUG] [o.o.p.jdbc.internal.JdbcMapper] - JDBC::pingDB
2016-01-29 12:18:23.405 [DEBUG] [o.o.p.jdbc.internal.JdbcMapper] - JDBC::openConnection isDriverAvailable: true
2016-01-29 12:18:23.406 [WARN ] [o.o.p.jdbc.internal.JdbcMapper] - JDBC::openConnection: setupDataSource.

I am running Openhab 1.8.0 release with default demo configuration (only renamed rrd4j.persist to jdbc.persist) on a Raspberry Pi with Raspian Wheezy:
Linux rpi 3.18.7+ #755 PREEMPT Thu Feb 12 17:14:31 GMT 2015 armv6l GNU/Linux

The JDBC driver used is:
sqlite-jdbc-3.8.11.2.jar (stored in addons folder)

SQLite3 version installed is:
3.7.13-1+deb7u2

openhab.cfg has this content (as per the JDBC Binding Wiki page):

jdbc:url=jdbc:sqlite:./testSqlite.db
jdbc:user=test
jdbc:password=test
jdbc:tableUseRealItemNames=true

Any idea what could be wrong?

A similar issue has been reported in the discussion of this topic:

Hi,
I’ve exactly the same problem on my RPi installation.

org.openhab.persistence.jdbc-1.8.1.jar
sqlite-jdbc-3.8.11.2.jar
java 1.8.0_65

My config:

jdbc:url=jdbc:sqlite: /opt/openhab/mydb.db (I also tried with ./mydb.db)
jdbc:user=openhab
jdbc:password=*******
jdbc:tableUseRealItemNames=true

jdbc.persist:

Strategies
{
// if no strategy is specified for an item entry below, the default list will be used
default = everyChange
}

Items
{

  • : strategy = everyChange, restoreOnStartup
    }

Starting in debug I’ve

22:57:08.081 [DEBUG] [o.p.j.i.JdbcPersistenceService:95 ] - JDBC::unsetItemRegistry
22:57:08.343 [DEBUG] [o.p.j.i.JdbcPersistenceService:90 ] - JDBC::setItemRegistry
22:57:08.345 [DEBUG] [o.p.j.i.JdbcPersistenceService:60 ] - JDBC::activate: persistence service activated
22:57:08.347 [DEBUG] [o.p.j.i.JdbcPersistenceService:214 ] - JDBC::updateConfig
22:57:08.349 [DEBUG] [p.j.internal.JdbcConfiguration:64 ] - JDBC::JdbcConfiguration
22:57:08.351 [DEBUG] [p.j.internal.JdbcConfiguration:72 ] - JDBC::updateConfig: configuration.size = 8
22:57:08.353 [DEBUG] [p.j.internal.JdbcConfiguration:77 ] - JDBC::updateConfig: url=jdbc:sqlite:/opt/openhab/domusSilicea.db
22:57:08.355 [DEBUG] [p.j.internal.JdbcConfiguration:87 ] - JDBC::updateConfig: found serviceName = 'sqlite’
22:57:08.357 [DEBUG] [p.j.internal.JdbcConfiguration:98 ] - JDBC::updateConfig: Init Data Access Object Class: 'org.openhab.persistence.jdbc.db.JdbcSqliteDAO’
22:57:08.359 [DEBUG] [ersistence.jdbc.db.JdbcBaseDAO:101 ] - JDBC::initSqlTypes: Initialize the type array
22:57:08.362 [DEBUG] [ersistence.jdbc.db.JdbcBaseDAO:74 ] - JDBC::initSqlQueries: 'JdbcSqliteDAO’
22:57:08.364 [DEBUG] [o.o.p.jdbc.db.JdbcSqliteDAO :42 ] - JDBC::initSqlQueries: 'JdbcSqliteDAO’
22:57:08.366 [DEBUG] [p.j.internal.JdbcConfiguration:105 ] - JDBC::updateConfig: dBDAO ClassName=org.openhab.persistence.jdbc.db.JdbcSqliteDAO
22:57:08.370 [DEBUG] [p.j.internal.JdbcConfiguration:144 ] - JDBC::updateConfig: user=openhab
22:57:08.372 [DEBUG] [p.j.internal.JdbcConfiguration:157 ] - JDBC::updateConfig: password= password.length=7
22:57:08.373 [DEBUG] [p.j.internal.JdbcConfiguration:182 ] - JDBC::updateConfig: tableUseRealItemNames=true
22:57:08.375 [DEBUG] [p.j.internal.JdbcConfiguration:216 ] - JDBC::updateConfig: enableLogTime false
22:57:08.377 [WARN ] [p.j.internal.JdbcConfiguration:237 ] - JDBC::updateConfig: try to load JDBC-driverClass: 'org.sqlite.JDBC’
22:57:08.379 [DEBUG] [p.j.internal.JdbcConfiguration:240 ] - JDBC::updateConfig: load JDBC-driverClass was successful: 'org.sqlite.JDBC’
22:57:08.380 [DEBUG] [p.j.internal.JdbcConfiguration:266 ] - JDBC::updateConfig: configuration complete. service=jdbc
22:57:08.382 [DEBUG] [o.o.p.jdbc.internal.JdbcMapper:33 ] - JDBC::pingDB
22:57:08.383 [DEBUG] [o.o.p.jdbc.internal.JdbcMapper:153 ] - JDBC::openConnection isDriverAvailable: true
22:57:08.385 [WARN ] [o.o.p.jdbc.internal.JdbcMapper:155 ] - JDBC::openConnection: setupDataSource.

No file is created. I read the old post but I’ve no idea how to progress. No error in the log that give me any direction for investigation.

Is there anyone that have any suggestion?

Thanks
hjfabius

@lewie do you have any thoughts about this?

So, the bundle could connect the database, wherever it was created.

The only thing, I don’t know how a [blank] is interpreted jet:
jdbc:url=jdbc:sqlite:[blank]/opt/openhab/mydb.db

Delete it and use:
jdbc:url=jdbc:sqlite:/opt/openhab/mydb.db

No more idea.

Helmut

I have tested it, definitely the [blank] causes problems!
Watou, please can you extend StringUtilsExt.java with this patch:

Thanks
Helmut

Thanks, @lewie, will do.

Hi,
Thanks for the feedback. Unfortunately also without space I’ve no luck. Same behavior. I’ve pingDB but no db created.
I also look for any file .db on the full file system but no success.

Any further ideas? Is there a way to see all the open SQLLite connections?

Thanks
Hjfabius

pingDB is nothing else as pure SQL (for Sqlite SELECT 1;).
If “pingDB” throws no error there must be a Database anywhere.

I cannot even get the sqlite-jdbc driver loaded:

16:11:22.585 [WARN ] [p.j.internal.JdbcConfiguration:237  ] - JDBC::updateConfig: try to load JDBC-driverClass: 'org.sqlite.JDBC'
16:11:22.609 [ERROR] [p.j.internal.JdbcConfiguration:243  ] - JDBC::updateConfig: could NOT load JDBC-driverClassName or JDBC-dataSourceClassName ClassNot
FoundException: 'org.sqlite.JDBC'
16:11:22.615 [WARN ] [p.j.internal.JdbcConfiguration:263  ] -

        !!!
        To avoid this error, place a appropriate JDBC driver file for serviceName 'sqlite' in addons directory.
        Copy missing JDBC-Driver-jar to your OpenHab/addons Folder.
        !!!
        DOWNLOAD: 
        SQLite:    version >= 3.8.11.2 from           http://mvnrepository.com/artifact/org.xerial/sqlite-jdbc

16:11:22.621 [DEBUG] [p.j.internal.JdbcConfiguration:266  ] - JDBC::updateConfig: configuration complete. service=jdbc

16:12:03.499 [DEBUG] [o.o.p.jdbc.internal.JdbcMapper:33   ] - JDBC::pingDB
16:12:03.505 [DEBUG] [o.o.p.jdbc.internal.JdbcMapper:153  ] - JDBC::openConnection isDriverAvailable: false
16:12:03.510 [WARN ] [o.o.p.jdbc.internal.JdbcMapper:160  ] - JDBC::openConnection: no driver available!

Archlinux on Raspberry Pi, Oracle Java 1.8.0, openHAB 1.8.1, openhab.cfg as per jdbc wiki.

Any idea?

EDIT: Okay, I got it working eventually.

I do not know exactly what the problem was. I had own compiled sqlite-jdbc driver in /usr/share/java/… and later on also the one downloaded from maven repository (in addons directory), plus Arch linux packager from some reason creates also addons/addons-enabled directory.
After cleaning up a bit (I removed the addons-enabled subdir, uninstalled my own sqlite-jdbc driver) I found that:

  • sqlite-jdbc-3.8.11.2.jar from maven repository leads to crash of JRE (SIGILL)
  • natively compiled sqlite-jdbc-3.8.11.2.jar works and db file is created by openHAB and data stored.
1 Like

Hi derka
Could you share you Jar? I’m still fighting to discover where the DB is created.
Thanks
Hjfabius

The Arch Linux installation package file is here (for two days only):
http://expirebox.com/download/bb7f96ea958f34bafecc88ed53777362.html

If you need only the jar file, you can easily extract it yourself (it is tar file with xz compression).

The sqlite db will be created in the path, which you define in the openhab.cfg (as per Wiki):
jdbc:url=jdbc:sqlite:./testSqlite.db
"." stands for the current dir, which should be openhab home dir (in my case /opt//openhab-runtime). Or you can use absolute path, too.

Hi @Derka,
thanks for the file. I did some test i’m even more confused than before.

Test 1) Copy my original configuration from my RPI to a windows machine and execute there.
Database created without problem.

Test 2) Copy your jar in the window machine and execute there.
Database created without problem.

Test 3) Copy your jar in the rpi and execute there.
Database created without problem.

Test 4) Copy the original jar in the rpi and execute there.
Database not created but pingDB found in the log.

Test 5) Copy back your jar in the rpi and execute there.
Database created without problem.

It’s like there is something incompatible between the original sqlite-jdbc-3.8.11.2.jar (downloaded from here and rpi (I even retried to re-download it but without success) and the one you provided me).

Am I the only one having this problem? For the time being i’m progressing with your file but it will be nice to discover the differences.

Thanks again
@hjfabius

Hi All,
i did some more test with the jar provided by @Derka.

Consider that my jdbc.persist file is defined as follow:
* : strategy = everyChange, everyMinute, restoreOnStartup

and I’ve one item bound to MQTT receiving by the meter the total usage of water.
Number ds_Water_GF_Bathroom "Water m3 [%.4f]" (ds_Group_MQTT) {mqtt="<[openhab:domus-silicea/GF_Bathroom/V_WATER_VALUE:state:default]"}

When I start openhab, the sqllite database is created. If I check, i’ve in there only 3 tables (items + 2 of my 100 items… I’ve no clue why only these two).

When a message from MQTT is received, in the log i’ve:
ds_Water_GF_Bathroom state updated to 0.04140000
and no further message.

if I open sqllite db, and I execute
SELECT * FROM ds_water_gf_bathroom_0002;
I don’t have any results.

I executed also in debug and no error message/more details are available…
It seems just that my ds_Water_GF_Bathroom is not persisted.

Other items are even in worst situation as the table in the db is not created.

Any suggestion where / how to investigate?

Thanks
@hjfabius

@hjfabius, have you enabled DEBUG or TRACE logging in logback.xml?

Sqlite has some parts written in C. Eventually missing dependencies? So eventually it could help to run
apt-get install sqlite3 on yout RPI.

@hjfabius, which working sqlite-jdbc-xxx.jar version did you get from Derka? Can you send it to me please? Thanks

I’m also trying to persist data to a MariaDB using the JDBC binding…

I’m testing with a very simple setup of just the weather binding grabbing temp data from WeatherUnderground every minute.

I’m persisting to both rrd4j and jdbc but nothing seem to ever get written to the database.

On startup, this is what I get in the log. You can see that the JDBC manages to connect to my database… If I delete the “Items” table from my database then it does recreate it. You can also see temperatures getting stored to the rrd4j persistence but nothing to JDBC :frowning:

11:06:56.114 [DEBUG] [o.p.j.i.JdbcPersistenceService:89 ] - JDBC::setItemRegistry
11:06:56.116 [DEBUG] [o.p.j.i.JdbcPersistenceService:59 ] - JDBC::activate: persistence service activated
11:06:56.119 [DEBUG] [o.p.j.i.JdbcPersistenceService:215 ] - JDBC::updateConfig
11:06:56.126 [DEBUG] [p.j.internal.JdbcConfiguration:64 ] - JDBC::JdbcConfiguration
11:06:56.128 [DEBUG] [p.j.internal.JdbcConfiguration:72 ] - JDBC::updateConfig: configuration.size = 8
11:06:56.133 [DEBUG] [p.j.internal.JdbcConfiguration:77 ] - JDBC::updateConfig: url=jdbc:mariadb://192.168.1.199:3306/OpenHAB
11:06:56.135 [DEBUG] [p.j.internal.JdbcConfiguration:87 ] - JDBC::updateConfig: found serviceName = 'mariadb’
11:06:56.138 [DEBUG] [p.j.internal.JdbcConfiguration:98 ] - JDBC::updateConfig: Init Data Access Object Class: 'org.openhab.persistence.jdbc.db.JdbcMariadbDAO’
11:06:56.162 [DEBUG] [ersistence.jdbc.db.JdbcBaseDAO:109 ] - JDBC::initSqlTypes: Initialize the type array
11:06:56.164 [DEBUG] [ersistence.jdbc.db.JdbcBaseDAO:82 ] - JDBC::initSqlQueries: 'JdbcMariadbDAO’
11:06:56.166 [DEBUG] [o.o.p.jdbc.db.JdbcMariadbDAO :45 ] - JDBC::initSqlTypes: Initialize the type array
11:06:56.169 [DEBUG] [o.o.p.jdbc.db.JdbcMariadbDAO :38 ] - JDBC::initSqlQueries: 'JdbcMariadbDAO’
11:06:56.171 [DEBUG] [p.j.internal.JdbcConfiguration:105 ] - JDBC::updateConfig: dBDAO ClassName=org.openhab.persistence.jdbc.db.JdbcMariadbDAO
11:06:56.175 [DEBUG] [p.j.internal.JdbcConfiguration:144 ] - JDBC::updateConfig: user=root
11:06:56.178 [DEBUG] [p.j.internal.JdbcConfiguration:157 ] - JDBC::updateConfig: password= password.length=16
11:06:56.181 [DEBUG] [p.j.internal.JdbcConfiguration:182 ] - JDBC::updateConfig: tableUseRealItemNames=true
11:06:56.184 [DEBUG] [p.j.internal.JdbcConfiguration:216 ] - JDBC::updateConfig: enableLogTime false
11:06:56.186 [WARN ] [p.j.internal.JdbcConfiguration:237 ] - JDBC::updateConfig: try to load JDBC-driverClass: 'org.mariadb.jdbc.Driver’
11:06:56.193 [DEBUG] [p.j.internal.JdbcConfiguration:240 ] - JDBC::updateConfig: load JDBC-driverClass was successful: 'org.mariadb.jdbc.Driver’
11:06:56.196 [DEBUG] [p.j.internal.JdbcConfiguration:266 ] - JDBC::updateConfig: configuration complete. service=jdbc
11:06:56.198 [DEBUG] [o.o.p.jdbc.internal.JdbcMapper:41 ] - JDBC::pingDB
11:06:56.200 [DEBUG] [o.o.p.jdbc.internal.JdbcMapper:161 ] - JDBC::openConnection isDriverAvailable: true
11:06:56.202 [WARN ] [o.o.p.jdbc.internal.JdbcMapper:163 ] - JDBC::openConnection: setupDataSource.
11:06:56.225 [INFO ] [zaxxer.hikari.HikariDataSource:70 ] - HikariPool-0 - is starting.
11:06:59.070 [INFO ] [.o.b.w.i.s.WeatherJobScheduler:147 ] - Starting and scheduling weatherJob-home with interval of 1 minutes
11:06:59.091 [DEBUG] [o.o.b.w.i.scheduler.WeatherJob:43 ] - Starting Weather job for location 'home’
11:06:59.731 [DEBUG] [.w.i.p.AbstractWeatherProvider:75 ] - WUNDERGROUND[home]: Weather[Temperature[current=12.2,min=,max=,feel=12.2,dewpoint=8.0],Atmosphere[humidity=78,visibility=10.0,pressure=1026.0,pressureTrend=equal,ozone=,uvIndex=1],Clouds[percent=],Condition[text=Overcast,lastUpdate=Sat Jun 18 11:06:59 NZST 2016,observationTime=Sat Jun 18 11:05:16 NZST 2016,id=,icon=cloudy,commonId=cloudy],Precipitation[rain=0.0,snow=0.0,probability=40,total=1.0],Wind[speed=1.8,direction=NNW,degree=339,gust=4.0,chill=],Station[name=Redoubt North School Manukau, Auckland, AUCKLAND,id=IAUCKLAN452,latitude=-36.985687,longitude=174.889755],]
11:06:59.733 [DEBUG] [.w.i.p.AbstractWeatherProvider:77 ] - WUNDERGROUND[home]: Forecast[day=0,Temperature[current=,min=11.0,max=16.0,feel=,dewpoint=],Atmosphere[humidity=72,visibility=,pressure=,pressureTrend=,ozone=,uvIndex=],Clouds[percent=],Condition[text=Mostly Cloudy,lastUpdate=Sat Jun 18 11:06:59 NZST 2016,observationTime=Sat Jun 18 19:00:00 NZST 2016,id=,icon=mostlycloudy,commonId=mostly-cloudy-day],Precipitation[rain=0.0,snow=0.0,probability=0,total=],Wind[speed=18.0,direction=SW,degree=227,gust=,chill=],Station[name=,id=,latitude=,longitude=],]
11:06:59.734 [DEBUG] [.w.i.p.AbstractWeatherProvider:77 ] - WUNDERGROUND[home]: Forecast[day=1,Temperature[current=,min=9.0,max=17.0,feel=,dewpoint=],Atmosphere[humidity=77,visibility=,pressure=,pressureTrend=,ozone=,uvIndex=],Clouds[percent=],Condition[text=Clear,lastUpdate=Sat Jun 18 11:06:59 NZST 2016,observationTime=Sun Jun 19 19:00:00 NZST 2016,id=,icon=clear,commonId=sunny],Precipitation[rain=0.0,snow=0.0,probability=0,total=],Wind[speed=21.0,direction=SW,degree=222,gust=,chill=],Station[name=,id=,latitude=,longitude=],]
11:06:59.736 [DEBUG] [.w.i.p.AbstractWeatherProvider:77 ] - WUNDERGROUND[home]: Forecast[day=2,Temperature[current=,min=12.0,max=17.0,feel=,dewpoint=],Atmosphere[humidity=86,visibility=,pressure=,pressureTrend=,ozone=,uvIndex=],Clouds[percent=],Condition[text=Partly Cloudy,lastUpdate=Sat Jun 18 11:06:59 NZST 2016,observationTime=Mon Jun 20 19:00:00 NZST 2016,id=,icon=partlycloudy,commonId=partly-cloudy-day],Precipitation[rain=0.0,snow=0.0,probability=0,total=],Wind[speed=11.0,direction=NE,degree=36,gust=,chill=],Station[name=,id=,latitude=,longitude=],]
11:06:59.737 [DEBUG] [.w.i.p.AbstractWeatherProvider:77 ] - WUNDERGROUND[home]: Forecast[day=3,Temperature[current=,min=15.0,max=17.0,feel=,dewpoint=],Atmosphere[humidity=82,visibility=,pressure=,pressureTrend=,ozone=,uvIndex=],Clouds[percent=],Condition[text=Overcast,lastUpdate=Sat Jun 18 11:06:59 NZST 2016,observationTime=Tue Jun 21 19:00:00 NZST 2016,id=,icon=cloudy,commonId=cloudy],Precipitation[rain=8.0,snow=0.0,probability=10,total=],Wind[speed=27.0,direction=NNE,degree=27,gust=,chill=],Station[name=,id=,latitude=,longitude=],]
11:06:59.738 [DEBUG] [.w.i.p.AbstractWeatherProvider:77 ] - WUNDERGROUND[home]: Forecast[day=4,Temperature[current=,min=13.0,max=18.0,feel=,dewpoint=],Atmosphere[humidity=94,visibility=,pressure=,pressureTrend=,ozone=,uvIndex=],Clouds[percent=],Condition[text=Rain,lastUpdate=Sat Jun 18 11:06:59 NZST 2016,observationTime=Wed Jun 22 19:00:00 NZST 2016,id=,icon=rain,commonId=rain],Precipitation[rain=39.0,snow=0.0,probability=90,total=],Wind[speed=29.0,direction=N,degree=2,gust=,chill=],Station[name=,id=,latitude=,longitude=],]
11:06:59.739 [DEBUG] [.w.i.p.AbstractWeatherProvider:77 ] - WUNDERGROUND[home]: Forecast[day=5,Temperature[current=,min=11.0,max=17.0,feel=,dewpoint=],Atmosphere[humidity=90,visibility=,pressure=,pressureTrend=,ozone=,uvIndex=],Clouds[percent=],Condition[text=Rain,lastUpdate=Sat Jun 18 11:06:59 NZST 2016,observationTime=Thu Jun 23 19:00:00 NZST 2016,id=,icon=rain,commonId=rain],Precipitation[rain=7.0,snow=0.0,probability=90,total=],Wind[speed=14.0,direction=NW,degree=309,gust=,chill=],Station[name=,id=,latitude=,longitude=],]
11:06:59.741 [DEBUG] [.w.i.p.AbstractWeatherProvider:77 ] - WUNDERGROUND[home]: Forecast[day=6,Temperature[current=,min=11.0,max=17.0,feel=,dewpoint=],Atmosphere[humidity=87,visibility=,pressure=,pressureTrend=,ozone=,uvIndex=],Clouds[percent=],Condition[text=Partly Cloudy,lastUpdate=Sat Jun 18 11:06:59 NZST 2016,observationTime=Fri Jun 24 19:00:00 NZST 2016,id=,icon=partlycloudy,commonId=partly-cloudy-day],Precipitation[rain=0.0,snow=0.0,probability=20,total=],Wind[speed=11.0,direction=WNW,degree=291,gust=,chill=],Station[name=,id=,latitude=,longitude=],]
11:06:59.743 [DEBUG] [.w.i.p.AbstractWeatherProvider:77 ] - WUNDERGROUND[home]: Forecast[day=7,Temperature[current=,min=12.0,max=18.0,feel=,dewpoint=],Atmosphere[humidity=86,visibility=,pressure=,pressureTrend=,ozone=,uvIndex=],Clouds[percent=],Condition[text=Chance of Rain,lastUpdate=Sat Jun 18 11:06:59 NZST 2016,observationTime=Sat Jun 25 19:00:00 NZST 2016,id=,icon=chancerain,commonId=few-showers],Precipitation[rain=8.0,snow=0.0,probability=40,total=],Wind[speed=32.0,direction=N,degree=11,gust=,chill=],Station[name=,id=,latitude=,longitude=],]
11:06:59.744 [DEBUG] [.w.i.p.AbstractWeatherProvider:77 ] - WUNDERGROUND[home]: Forecast[day=8,Temperature[current=,min=11.0,max=17.0,feel=,dewpoint=],Atmosphere[humidity=80,visibility=,pressure=,pressureTrend=,ozone=,uvIndex=],Clouds[percent=],Condition[text=Chance of Rain,lastUpdate=Sat Jun 18 11:06:59 NZST 2016,observationTime=Sun Jun 26 19:00:00 NZST 2016,id=,icon=chancerain,commonId=few-showers],Precipitation[rain=8.0,snow=0.0,probability=60,total=],Wind[speed=29.0,direction=NW,degree=314,gust=,chill=],Station[name=,id=,latitude=,longitude=],]
11:06:59.745 [DEBUG] [.w.i.p.AbstractWeatherProvider:77 ] - WUNDERGROUND[home]: Forecast[day=9,Temperature[current=,min=10.0,max=15.0,feel=,dewpoint=],Atmosphere[humidity=80,visibility=,pressure=,pressureTrend=,ozone=,uvIndex=],Clouds[percent=],Condition[text=Chance of Rain,lastUpdate=Sat Jun 18 11:06:59 NZST 2016,observationTime=Mon Jun 27 19:00:00 NZST 2016,id=,icon=chancerain,commonId=few-showers],Precipitation[rain=2.0,snow=0.0,probability=40,total=],Wind[speed=31.0,direction=WNW,degree=283,gust=,chill=],Station[name=,id=,latitude=,longitude=],]
11:07:26.256 [INFO ] [.zaxxer.hikari.pool.HikariPool:214 ] - HikariPool-0 - is closing down.
11:07:31.268 [DEBUG] [o.p.j.i.JdbcPersistenceService:94 ] - JDBC::unsetItemRegistry
11:07:31.292 [DEBUG] [.p.rrd4j.internal.RRD4jService:132 ] - Stored ‘WTH_Temperature’ with state ‘12.20’ in rrd4j database
11:07:31.305 [DEBUG] [.p.rrd4j.internal.RRD4jService:132 ] - Stored ‘WTH_Temp_Feel’ with state ‘12.20’ in rrd4j database

My “persist” files are both pretty much identical…
jdbc.persist

Strategies {default = everyChange}
Items {AllItems* : strategy = everyChange}

I also set the default persistence to be jdbc too

persistence:default=jdbc

Any assistance would be greatly appreciate…

I have the exactly same problem in openhab2.

My items:

Number ESP_Temp01 “Temperatura [%.1f °C]” (gC_Furnace, gTemperature) {mqtt="<[mosquitto:/DOM/ESP-10763452/temperatura/:state:default]"}

My “persist”

Strategies {
everyMinute : "0 * * * * ?"
everyHour : "0 0 * * * ?"
everyDay : “0 0 0 * * ?”

default = everyChange
}

Items {
ESP_Temp01 : strategy = everyChange, everyHour, everyMinute, restoreOnStartup
}

in idbc uncomment only:

url=jdbc:sqlite:/usr/share/openhab2/testSqlite.db

Openhab.log:

2017-01-20 17:24:41.265 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model 'postgre.persist’
2017-01-20 17:31:14.570 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model 'postgre.persist’
2017-01-21 11:49:31.329 [INFO ] [persistence.jdbc.internal.JdbcMapper] - JDBC::logTime: ‘insertItemValue’:
afterAccess = 6 ms
timeAverage50 = 52 ms
timeAverage100 = 52 ms
timeAverage200 = 52 ms
afterAccessMin = 0 ms
afterAccessMax = 150 ms
1000Statements = 0 sec
statementCount = 12

2017-01-21 11:49:31.331 [INFO ] [persistence.jdbc.internal.JdbcMapper] - JDBC::logTime: ‘insertItemValue’:
afterAccess = 3 ms
timeAverage50 = 48 ms
timeAverage100 = 48 ms
timeAverage200 = 48 ms
afterAccessMin = 0 ms
afterAccessMax = 150 ms
1000Statements = 0 sec
statementCount = 13

Openhab2 was created /usr/share/openhab2/testSqlite.db

PRAGMA foreign_keys=OFF;
BEGIN TRANSACTION;
CREATE TABLE items (ItemId INTEGER PRIMARY KEY AUTOINCREMENT, itemname VARCHAR(500) NOT NULL);
COMMIT;

But nothing write inside.

Are you fix it?