Jeeling binding working with DIY nanoCUL?

Hello Community!
I´m a beginner wiith smarthome things and before trying around with openhab2 i played a little with FHEM.

Here is my smarthome situation:

  • 3x eq3 bluetooth radiators ~20€ / radiator
  • 1x broadcom USB bluetooth dongle to connect the radiators
  • 1x nanoCUL Do It Yourself (DIY) USB dongle
  • 1x Technoline TX 29 DTH - IT sensor (temperature and humidity)

I was able to integrate all this into FHEM to read the values and draw some diagrams.
But i wanted to use Openhab2, because the way of configure stuff looks better and have more structure.

So i´ve read a lot around Openhab2 and integrate LaCrosse (Technoline and so on…) temperature sensors and i always ended up in the thread of this binding from @vbier.
So my challenge is that i have an nanoCUL built up on my own for my old FHEM installation and now i ask me if it is possible to use this nanoCUL to integrate it into openhab2.
Now i want to replace FHEM with Openhab2.
The Dongle was built with this howto here:
And i flashed the alternatativ firmware from here:,35064.0.html

Now i downloaded a snapshot version of your binding from here: [www]frombeyond[de]/2017/openhab-jeelink-einrichten-lacrosse/
Then i restarted my Openhab2 and can manage the binding with the PaperUI.
But after configuring the Jeelink USB receiver i got this error: Status: OFFLINE - COMMUNICATION_ERROR Port not found: /dev/ttyUSB0
And so i first recognized your hint above that now only LaCrosseITPlusReader and ec3kSerial Sketches are supported.

So, can you help me out @vbier ? Or does anyone else have an idea with an LaCrosse DIY USB dongle?

Best regards

PS: Sorry the webform told me that new users can only add 2 links here and so i encrypt the last link a bit.


dmesg -T | grep tty

to find out if you have configured the correct port.

i tried it out and got this:

dmesg -T | grep tty
[Tue Dec 5 06:00:19 2017] console [tty0] enabled
[Tue Dec 5 06:00:24 2017] systemd[1]: Starting system-getty.slice.
[Tue Dec 5 06:00:24 2017] systemd[1]: Created slice system-getty.slice.
[Tue Dec 5 06:00:25 2017] usb 1-1.1: FTDI USB Serial Device converter now attached to ttyUSB0

So it is correct configured.

Find out via karaf console if you have the serial driver installed:

openhab> bundle:list|grep serial
 26 │ Active   │  80 │ 3.12.0.OH              │ nrjavaserial

If not, install via

feature:install openhab-transport-serial

i checked this:

openhab> bundle:list | grep serial
186 | Active | 80 | 3.12.0.OH | nrjavaserial

openhab> feature:install openhab-transport-serial

openhab> bundle:list | grep serial
186 | Active | 80 | 3.12.0.OH | nrjavaserial

So i think it was already installed or?

Mh, no idea someone??


I can confirm the same behavior with a original jeelink dongle.
It’s workign fine under fhem with a Lacross sketchfile and the /dev/ttyUSB configuration.

I have just setup a vanilla OH 2.2.0 and included the jeelink binding. When I connect to the OH2 console, I get the same error message, that the binding can’t open the /dev/ttyUSB0 port:
21:39:41.625 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘jeelink:jeelinkUsb:a8a12275’ changed from INITIALIZING to OFFLINE (COMMUNICATION_ERROR): Port not found: /dev/ttyUSB0

I have restartet my server just to be sure, that no other application uses /dev/ttyUSB0

Is there any way to get more log output?
As I have a little bit of Java/OSGi experience, but none withe serial ports: is there an application I can test the connection from karaf to the serial port? @vbier how do you check the connection during development?

As this is my first post: Thanks for this great software - I love OH :smiley:


Increasing the loglevel for the jeelink binding and nrjavaserial didn’t provide any new insights.

I assume my and maybe also the issue of @Darkentik is related to this post: New Jeelink Openhab2 Binding

Just tried the newest version of nrjavaserial by building and exchanging it in OH2.

The Jeelink bundle did start, but I get the same error message…
Right now I have no idea how to dig deeper.

Found it: in my case I startet openhab with a dedicated linux user, which didn’t have access rights for /dev/ttyUSB0
As I always started fhem as root, it worked there.

Are you using an openhabian image to install openHAB ( that would include the OS) or just install an openHAB on a ready system?

I´m using OH2 at a standard Debian Jessie. I´ll check which user is running the OH2 and tries to use /dev/ttyUSB0.

I used to have problems using a serial device for the intertechno binding which logged an error (“Can’t open CUL”). Since the error text was coming from the bindning, it could be related although your text is different.
My problem was solved by switching to the use of the openHABian image. Before that I had to start OH as root to make it work as well.
I have to digg into older threads to find the change which made the usage possible.

Again, that only migth be related to your problem.

I use OH2 on Gentoo.