Jeelink - Issues with COM after a while

Is anyone else having issues with JEELINK binding. worked great for years on OH2, now with OH3 migration (clear setup) i have communication, all works fine, but during the night the communication is lost and i have to restart openhab.

Its OH3.2- latest dev build
Communication is via COM - interface.

It says COMM-Error with “RED” - but as soon as i disable the “thing” and enable again,
its ONLINE immediately…due to this it does not look like there is any issue of the COM port at all.

Thanks for your thougths…(any idea @vbier )

Here a sample OutsideTemp:


Do you have anything interesting in the logs?

Thanks for your reply. in the standard logs there is nothing, but now did switch to debug. will take some time until it crashes again.

Please try to cat your jeelink device while it is working. If you see sensible output, wait until it no longer works and try again to check If it behaves differently.

right now it works…but i see a lot of this, that was not present all the weeks of OH3 migration before.

2021-08-07 14:56:12.058 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler JeeLinkHandler tried updating the thing status although the handler was already disposed.

BUT the USB-connection is still online…

Or is this due to the DISABLE and ENABLE Thing (USB-Bridge)

Most likely.