Jetty update, Karaf 4.1.3 upgrade and full LSP support

jetty
karaf
vscode
Tags: #<Tag:0x00007f014cd9b350> #<Tag:0x00007f014cd9b1c0> #<Tag:0x00007f014cd9b008>

(Geri) #41

Thats really interesting. I have now checked my addon.cfg and recognized that also with an update to #1088 this file is empty. Everything is commented out.
Maybe thats the point where all of those issues coming from?

My installation still hangs with installing UI …


(houz) #42

Hooray, that was it! After fixing the bool value I can control my lights and blinds again. :smile:


(Geri) #43

I can now confirm that also fixed all my tons of errors after the upgrade.
I just reinstalled the bindings which i havent all listed within the addons.cfg file.

It is the case that after upgrading this file is not getting migrated but getting completely overwritten. i just activated necessary lines (everything was commented out).

Now everything works again and being on #1088.

Maybe someone can look into it why addons.cfg is not “migrated” properly when doing an upgrade - this saves a lot of time to people :slight_smile:
hooray


(Daniel Malmgren) #44

I don’t know if this is helping, but I just checked my /var/lib/openhab2/etc/org.openhab.addons.cfg and it looks exactly like @houz one, I’ve also got the B"true". I’m running build 1073 (didn’t dare upgrading last few days because of the known problems) and everything is working like a charm here.

Pasting the entire file below:

package = "standard"
ui = "basic,paper,habmin"
remote = B"true"
binding = "tellstick,expire1,exec,sonos"
persistence = "jdbc-mysql"
action = "mail"
transformation = "regex"
voice = "voicerss"


(Georg Willmann) #45

i’ve read the whole thread and have been following all the leads, but still nothing works. Here the first error message:

2017-11-21 21:45:00.709 [ERROR] [org.openhab.binding.pilight         ] - FrameworkEvent ERROR - org.openhab.binding.pilight
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.pilight [11]
  Unresolved requirement: Import-Package: org.openhab.core.binding

After some more exceptions it results in the following error:

2017-11-21 21:45:03.827 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-binding-exec, openhab-binding-enocean1, openhab-persistence-"mysql, openhab-binding-"avmfritz, openhab-binding-caldav-command1, openhab-ui-habpanel, openhab-transformation-"map, openhab-transformation-regex, openhab-ui-"classic, openhab-binding-lgtv1", openhab-persistence-rrd4j", openhab-ui-basic, openhab-binding-caldav-personal1, openhab-ui-habmin", openhab-transformation-xslt, openhab-transformation-exec, openhab-transformation-jsonpath", openhab-ui-paper, openhab-misc-"restdocs", openhab-binding-onkyo': Error:
	Error downloading mvn:org.openhab.binding/org.openhab.binding.caldav-personal/1.11.0-SNAPSHOT

after all it still hangs with “please stand by while UIs are being installed. This can take several minutes.”

I’ve upgraded from Build #1082 to Build #1088 running ‘runtime/bin/update’, platform is a raspberry pi 3, openhab is installed in /opt/openhab2 as described here.


(Rich Koshak) #46

@benjy, you work a lot with the upgrade scripts and such, do you have any ideas? To summarize, people are upgrading to recent builds and their addons.cfg are becoming corrupted. See Daniel’s posting for an example.


The last assembly does not work
(Ben Clark) #47

Woah this is odd. I doubt it has anything to do with the upgrade scripts, in both apt and the manual script org.openhab.addons.cfg is untouched.

@Schorsch would you be able to post the contents of your /opt/openhab2/userdata/etc/org.openhab.addons.cfg?

I suspect that the first launch of a rogue snapshot is trying to configure it this way. But would like to compare the file on different instalation methods first.


(Daniel Malmgren) #48

For how long have they been untouched? I mean, this might very well have been in my config for a while, I seldom check the contents of that file. And everything seems to work fine anyway until OH is upgrading to 1083+.


(Georg Willmann) #49

In the meantime i made a reinstallation of OH2 and restored the backup (without tmp and cache). Now it works like a charm and better than ever bevor. The /opt/openhab2/userdata/etc/org.openhab.addons.cfg file is now “clean”, without “B” and and quotiation marks. I don’t know what the problem was, but it doesn’t matter. Best OH2 till now.


(Thomas Binder) #50

with backup I assume you just pasted the config files from /etc/openhab2/* ?


(Kai Kreuzer) #51

It is definitely not related to the upgrade scripts. My assumption is that this is due to an changed behavior of Felix FileInstall which has been updated to a more recent version in Karaf 4.1.3.
FileInstall writes such files as well, if configs are edited through Config Admin (e.g. by the Paper UI).
I’ll try to figure out what causes the file to be written by FileInstall here in the first place and also what goes wrong when parsing such a file. I have entered an issue for it.


(Georg Willmann) #52

yes. Bevor reinstalling OH i’ve modified the /opt/openhab2/userdata/etc/org.openhab.addons.cfg, since it was also wrong formatted as described here in this thread. Unfortunately i’ve not checked, how the file looks like directly after unpacking the new version.


(SiHui) #53

Similar issues where already reported 30 days ago:


(N. Jordan) #54

having the same issue coming from 1074 to latest release.

Is there any quick fix/trick i could try. going back did not solve the situation. Trying to start immediately results in the log issues named above. Thanks a lot Norbert


(Daniel Linder) #55

my logging died. cannot tell what my issue is. :thinking:
any suggestions what to try?


(Geri) #56

Hello Norbert,

check your addons.cfg file. Mine was completely empty after the upgrade and i just put in a few values:

package = standard
ui = basic,paper,habmin
remote = true
persistence = jdbc-mysql
action = mail

After that stop Openhab, clear cache and start OH again. All of the erros then went away.I am now on fully working #1088 at the moment and came from same version as you…

Cheers,


(Markus) #57

Is there actually a relationship between this warning

and the quotes issue in this file?

Or are these two completely different things?


(Kai Kreuzer) #58

I doubt that there is a relation.


(Dries) #59

@mas: I don’t think there is a relation. I never had the corrupt org.openhab.addons.cfg file.

I’m currently on #1094. No issues so far.


(Markus) #60

My org.openhab.addons.cfg isn’t also “corrupted”. But I have several config files that look like this. For example, the network bindings config file: “openhab2-userdata\config\binding\network.config”

allowDHCPlisten=B"true"
allowSystemPings=B"true"
arpPingToolPath="arping"
cacheDeviceStateTimeInMS="2000"
service.pid="binding.network"

All the booleans are preceded by a B in quotation marks. I do not think that all such files are broken.