[JVM11] Trouble with initial install

openhab2
macos
java11
Tags: #<Tag:0x00007f0147418788> #<Tag:0x00007f0147418620> #<Tag:0x00007f01474184b8>

(Gerard) #1

MacOs X El Capitan ver 10.11.6
I get the following error when running start.sh

Error installing bundle listed in startup.properties with url: mvn:org.apache.karaf.features/org.apache.karaf.features.extension/4.1.5 and startlevel: 1

Java version:
openjdk version “11.0.1” 2018-10-16 LTS
OpenJDK Runtime Environment Zulu11.2+3 (build 11.0.1+13-LTS)
OpenJDK 64-Bit Server VM Zulu11.2+3 (build 11.0.1+13-LTS, mixed mode)


(Angelos) #2

downgrade to a JVM 8 plz
JVM 11 support is coming but it’s not here yet


(Gerard) #3

Thank for the help. I am new to mac thus not always sure I do the right thing.

I tried was you suggested and this is the result:

gerard-MBP-3:openhab gerardsch$ java -version
java version “1.8.0_191”
Java™ SE Runtime Environment (build 1.8.0_191-b12)
Java HotSpot™ 64-Bit Server VM (build 25.191-b12, mixed mode)

gerard-MBP-3:openhab gerardsch$ ./start.sh
Launching the openHAB runtime…
Error installing bundle listed in startup.properties with url: mvn:org.apache.karaf.features/org.apache.karaf.features.extension/4.1.5 and startlevel: 1

Is there more changes required?


(Angelos) #4

check folder permissions
the OH2 process runs as user openhab and it may not be able to access all files and folders


(Gerard) #5

erard-MBP-3:~ gerardsch$ ls -l
total 0
drwx------+ 4 gerardsch staff 136 Nov 22 21:26 Desktop
drwx------+ 4 gerardsch staff 136 Aug 28 2016 Documents
drwx------+ 15 gerardsch staff 510 Nov 25 14:52 Downloads
drwx------@ 52 gerardsch staff 1768 Aug 28 2016 Library
drwx------+ 3 gerardsch staff 102 Feb 14 2016 Movies
drwx------+ 4 gerardsch staff 136 Feb 21 2016 Music
drwx------+ 4 gerardsch staff 136 Feb 14 2016 Pictures
drwxr-xr-x+ 5 gerardsch staff 170 Feb 14 2016 Public
drwxr-xr-x 20 gerardsch staff 680 Nov 24 17:52 karaf
drwxr-xr-x 11 gerardsch staff 374 Nov 24 11:21 openhab


(Angelos) #6

I am not familiar with Mac… I may be wrong about the permissions …

did you follow the instructions here:

  1. https://www.openhab.org/download/
  2. https://www.openhab.org/docs/installation/macos.html

(Gerard) #7

Thanks for the effort. Hope someone with mac knowledge will help. I would really like to use this laptop for openhab.

Lets hope!


(Gerard) #8

Dim

Do you think someone else might help me or must I post in a different section?


(Angelos) #9

There will be others to help, I am sure :slight_smile:
This is the right category to ask this type of questions.

Can you try to use the latest Milestone to see if things improve: [OH 2.4.0 M6] Testing Results

remove the existing OH2.3.0 Stable installation, download 2.4.0.M6 and try to start it up


(Gerard) #10

That worked
Thanks


(Angelos) #11

M7 is out now :slight_smile: