KEBA Binding does not update current value on wallbox with openHAB 4.0.1

Hello everyone

We migrated from openHAB 3.4.5 to 4.0.1. Our openHAB instance runs on a Raspberry PI, installed with openhabian. Before the migration, openHAB was able to update the current of our KEBA wallbox so we we were able to load surplus solar power into our EV. Since the upgrade, openHAB does no longer update the currend on our wallbox, it only reads the values. Therefore our solar rules do not work anymore.

Is there something we have to change in the configuration to get it working again? Sorry if we missed something when upgrading. Any help is highly appreciated :slight_smile: Please also let me know if I missed to post some information as I’m no regular in this community :slight_smile:

Best regards, Richie

Same problem here. Cannot set the channel “maxpresetcurrent” for the current charging session which worked flawlessly with openHAB 3.x.

After unlinking all items, removing the Keba thing, adding a new Keba thing and linking all items to the new Keba thing everything works like before.
Don’t know what messed up the old Keba thing.

In my setup this didn’t help, but the wallbox still does not send back information:

2023-10-10 23:34:04.727 [DEBUG] [ba.internal.handler.KeContactHandler] - Running pollingRunnable to connect Keba wallbox
2023-10-10 23:34:04.728 [DEBUG] [ba.internal.handler.KeContactHandler] - isKebaReachable() returns true
2023-10-10 23:34:04.797 [DEBUG] [nternal.handler.KeContactTransceiver] - Sending 'report 1' on the channel '/'->'/'
2023-10-10 23:34:07.728 [DEBUG] [ba.internal.handler.KeContactHandler] - Missing response from Keba station for 'report 1'
2023-10-10 23:34:10.809 [DEBUG] [nternal.handler.KeContactTransceiver] - Sending 'report 2' on the channel '/'->'/'
2023-10-10 23:34:13.729 [DEBUG] [ba.internal.handler.KeContactHandler] - Missing response from Keba station for 'report 2'
2023-10-10 23:34:16.818 [DEBUG] [nternal.handler.KeContactTransceiver] - Sending 'report 3' on the channel '/'->'/'
2023-10-10 23:34:19.729 [DEBUG] [ba.internal.handler.KeContactHandler] - Missing response from Keba station for 'report 3'

Maybe a silly question but… DIP switch 1.3 is set to “ON”?

You could also try whether the wallbox responds to Modbus requests. Software like “qModMaster” is capable of communicating via Modbus TCP.

Not silly in general, but in my case nothing was changed at the DIP switch.

But found the reason by myself: I had a second parallel tool running also communicating with the wallbox and it seems that UDP answers were sent there instead of my OH instance.

Hi everyone

So you all were able to get it working? We still struggle with setting the power level.

In the meantime we switched back to OH3 but now OH3 seems to be broken (it always wants to install OH4 bindings even if we configure it not to do so). Now we are back on OH4 but we still do not get it working. We can switch it on and off and read all the values but we cannot change the power settings (which worked on OH3).

This problem occurs also in all openhab versions 4.x installed with docker-images on Synology NAS and it works in all openhab 3.x versions with docker-images on Synology NAS.
We now have the modbus binding in use. This allows us to update the Keba-Value Curr User.
See also the issue #15876