KM200 Binding channels disappearing

I´m using the KM200 binding in OH 2.4.0 connected to a Buderus Logano Plus GB212.
Installation and setup worked as expected and i integrated a few things/channels to my sitemap via Paper UI.

But some of the channels i integrated suddenly disappeared. From a few channels of the Thing named “appliance” only one is left:

A few others i that i used before are no longer available:

Restarting OH and the Buderus unit did not help.

How can i get back these channels?

Best regards

Hello Thomas,

the channels depend on the services discovered during the startup of the binding (It queries for a full blown list).
It happens that not all the data is send by the Buderus device, leaving some orphaned channel behind. In my setup the channels appear after some time or after a restart.

What has some influence as well, besides the heating model connected, is the firmware of the Buderus gateway - in case it gets updated some channels may no longer be available, some others may arise.
As the services have never been made public through an API by the vendor this is somehow a blackbox.
Maybe you could clear the OH cache and try again, it could be that some stuff is still there that causes the trouble.
@Markinus somehow has a very hard time to resolve these issues, as obviously he can´t have all possible model, controller types and firmwares, gateways and gateway firmwares available.
The vendor of the gateway hasn´t made the impression of being interested in any cooperation when coming to home automation based on Open Source software - neither the encryption algorithm nor the API has been mad public. It´s all reverse engineering, lucky guessing and lots of tracing.
@Markinus is doing his best within his limited available time.

What you could try is to update to OH 2.5 M1 and get the latest binding version from this thread . For me this has proven to be the most stable combination.


Thank you for answering.

As i said, the channels worked for some time and then stopped working. Restarting the device or OH did not help.

The system is not connected to the internet only local LAN and no service has been done to the machine physically. I doubt there has been a firmware update i don´t know of??

First i try this and then i try updating to 2.5.

Thanks again.

I had similar issues with 2.4 and the binding version contained - the binding stopped reading from the gateway after some time, some channels did no longer show up etc.
The maintainer hardened the implementation in the meantime, making it much more stable.
Ensure that you really remove the complete previous version before putting the latest version into the add-on folder (Check within karaf console!), otherwise it may behave very strange.

For me it is now running stable for weeks.

After updating to OH 2.5.0.M1 and installing the latest KM200 JAR unfortunately nothing changed. The mentioned channels did not show up again :frowning:

Too bad. At least the “System pressure” was nice to have.


2019-07-25 11:26:00.978 [ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method 'ThingHandler.dispose()' on 'org.openhab.binding.km200.internal.handler.KM200GatewayHandler@ba138e2': hexString needs to have an even length:

2019-07-25 11:27:37.524 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler KM200GatewayHandler tried updating the thing status although the handler was already disposed.

2019-07-25 11:27:37.907 [INFO ] [ery.KM200GatewayDiscoveryParticipant] - Discovered a KMXXX gateway with name: 'iCom [gateway_853351154]' id: '853351154'

2019-07-25 11:27:42.579 [WARN ] [core.thing.internal.ThingManagerImpl] - Initializing handler for thing 'km200:kmdevice:853351154' takes more than 5000ms.

2019-07-25 11:38:37.195 [ERROR] [00.internal.handler.KM200DataHandler] - Communication is not possible!


it looks for me like a wrong key in the configuration.