KNX and Tasmota powered switches

So I’m a bit stuck here.

For Christmas I use some Tasmota powered switch, so I can turn on/off some lights. I also want to have the feedback GA, so I can see on my KNX sensors, if the light is on or off.

So, what I did is:

  1. Use Tasmota powered switch
  2. configure a MQTT for the switch
  3. let openHAB turn switch on/off

So far so good, works as intended [1]

  1. use KNX GAs for switch (1/0/50) and feedback (1/0/53) for the sensor LED
  2. use a KNX non-KNX thing (switch-control) with those GAs: 1/0/50+1/0/53 [2]
  3. If the switch is used, the 1/0/50 gets send, but not the 1/0/53?

Do I miss something?

[1] configuration for MQTT:

  - id: Power2
    channelTypeUID: mqtt:switch
    label: Licht Weihnachten
    description: null
      commandTopic: cmnd/D1MiniRelay/POWER2
      stateTopic: stat/D1MiniRelay/POWER2
      off: OFF
      on: ON

[2] configuration for KNX:

  - id: XmasLicht
    channelTypeUID: knx:switch-control
    label: Licht Weihnachten
    description: ""
      ga: 1/0/50+1/0/53

The item is linked to both channels (Standard - Profile).

So, how do I manage to let OH3 send the feedback telegram also?

When the linked Item state changes, by whatever means, KnX binding attempts to send.

That’s exactly how its supposed to work, only sends to first, others are ‘listening’.

xxx-control type KNX channels are assumed to be control devices e.g. a glass panel. So incoming instruction (if any) is turned into command to Item. Item state change is sent to device, e.g. turn on an indicator LED.

1 Like

Oh yeah, I keep forgetting that. So I basically need another item for feedback and let it “follow” the switch item? This would send to 1/0/53 then…

Or…? I won’t need 1/0/50 anyways and I could use 1/0/53 only…?

I’ll try it tomorrow…