KNX Binding OH 3 MDT Router

Hello

I have some trouble implementing the OH bridge to my KNX installation.
It worked in the past with my demo board and a different interface.
Now i have a MDT router (disabled IP secure) and i cannot get it to work.

The device shows as ONLINE in the Things overview but my item does not fire.
Hope you can help.

If i try tunneling and specify the IP address of the router the thing changes to “unknown” and eventually to “offline” with the following log entry:

2021-02-05 10:07:08.766 [ERROR] [Xnet/IP Tunneling 192.168.2.117:3671] - establishing connection failed, timeout connecting to control endpoint /192.168.2.117:3671

I double checked the IP address.

Should i use tunneling instead of router? I tried that but the device is not coming online.
The manual says the router can establish up to 4 Tunnel connections to the bus.
If i use tunneling in the future do i have to make any configuration or will the router take care of the “clients” like Openhab or programming the bus in the ETS?

Thank you!

Things file:

Bridge knx:ip:bridge [
    type="ROUTER",
    //ipAddress="192.168.2.117",
    autoReconnectPeriod=60 //optional, do not set <30 sec.
] {
    Thing device knx_device "MDT_IP_Router" @ "Technikraum" [
        //readInterval=3600 //optional, only used if reading values are present
    ] {
Type switch                         :   EG_Licht_Technikraum_Schalten            "Technikraum Licht" [ ga="0/1/4" ]
    }
}

items file:

Switch        KG_Licht_Technikraum_Schalten         "Licht [%s]"               <light>          { channel="knx:device:bridge:knx_device:EG_Licht_Technikraum_Schalten" }

Hi,

I have the same MDT IP-router (with IP secure on). I have It working perfectly in tunneling mode. I’m not at my installation at the moment but I believe that the only settings that I put in the config was the IP address and port.
I can see in ETS that OpenHAB is sending commands (and obviously I can see the lights etc dim and such).

1 Like

Hi, have you configured your router to route or filer telegrams from KNX->IP and vice versa (in ETS)? I use a Schneider router (in router mode) and initially forgot to change from filter to routing (both ways) resulting in the same errors you describe.

My knx.things file looks like this (part of the file)

Bridge knx:ip:bridge [ type="ROUTER" ]
  {
         Thing device digitalIO "Jung IO" @ "KNX" [
         address="1.1.1",
         fetch=true,
         pingInterval=300,
         readInterval=3600 ]
         {
            Type switch-control  : switch1   "Control Switch 1"        [ ga="1/1/1" ]
            Type switch-control  : switch2   "Control Switch 2"        [ ga="1/1/2" ]
            Type switch-control  : switch3   "Control Switch 3"        [ ga="1/1/3" ]
         }
  }
1 Like

Hi!

I tried it with switch control but no use.
can you please show me your items file? I guess it may be the channel.
i indeed set a filter but did “pass through” everything now with no success.

Thank you in advance.

Hi,
I don’t use item files in OH3 because I find it easier to model and create items in the GUI, but I did in OH2 and one of the items was configured like this:

Switch oneSwitch1 “Light [%s]” { channel=“knx:device:bridge:digitalIO:switch1” }

You state that you

i indeed set a filter but did “pass through” everything now with no success.

Perhaps I misunderstand you, but you need to change FROM filter TO route in the KNX->IP and IP->KNX setup in ETS… and another thing… the reason I use switch-control in the things files is because I use the KNX switches to control other things (IKEA Trådfri) and therefore don’t store state in the KNX switch. You should most likely use switch type.

1 Like

Yep,

i also thought just “switch” would be right.
I am sure the KNX Router “routes” now as desired - because i also use a Heat-Pump service Gateway with a KNX plugin - and i can read values from that one (i could not before because it was filtered so - thanks for that :wink:

i’ll dig deeper into that tomorrow.
Now i have to get my lights going :slight_smile:

what are you doing with the “fetch”-feature?

Hello

unfortunately it is still not working.
i am pretty sure it is because i am using docker on os x.

i cannot define “network = host” because this setting does not work on mac os.
but i forwarded all the ports:

version: ‘2.2’

services:
openhab3:
image: “openhab/openhab:milestone”
restart: always
ports:
- 8080:8080
- 8443:8443
- 8101:8101
- 3671:3671
- 5007:5007
- 1012:1012
volumes:
- “/etc/localtime:/etc/localtime:ro”
- “/etc/timezone:/etc/timezone:ro”
- “./openhab/addons:/openhab/addons”
- “./openhab/conf:/openhab/conf”
- “./openhab/userdata:/openhab/userdata”
environment:
OPENHAB_HTTP_PORT: “8080”
OPENHAB_HTTPS_PORT: “8443”
EXTRA_JAVA_OPTS: “-Duser.timezone=Europe/Berlin”

still no success.
if i configure TUNNEL the thing never goes online. If i configure router the thing shows online but i cannot send or receive anything to or from the bus.

Finally.
Using Tunnel and activating useNAT=true did the trick!