KNX Changed from Tunnel to Router makes a lot of Loginfo?

Hello Guys.
I’m using KNX Binding version 1.9 (installed from PaperUI on OH2)
It worked correctly, when using it in Tunnel mode, but now i wanna set it to be in Router Mode, this makes a million lines in my log file - but the communication works, i get this:

[Link notifier] process link 224.0.23.12:3671: unsupported APDU service - ignored, service code = 0x240

and also

Ignoring local Event, received from my local Source address 15.15.2 for Group address 0/2/100.

I’ve set the ignorelocalevent=True in the config file, also when running Tunnel Mode.

Why is all this now generated? Pretty annoying

Hi,

First of all, make sure that the syntax is correct in your /etc/openhab2/services/knx.cfg

ignorelocalevents=true

(“ignorelocalevents”, not “ignorelocalevent”)

Add also a Local KNX Binding bus address in the same file:

busaddr=1.2.200

Make sure that this PA is free in your existing KNX Bus.

If these 2 changes do not help, let me know your KNX/IP Router model as well as put the binding in debug mode and post some logs.

ssh openhab@localhost -p 8101 (with password habopen)
log:set TRACE org.openhab.binding.knx
log:set TRACE tuwien.auto.calimero

Have you enabled “Reliable Communications” in your ETS for your KNX/IP Router? Try disabling this option to see if the “unsupported APDU service” exception goes away.

BR,
Dim

Check - done correct

Done…

Will test it…

The interface is ABB Ipr/s 2.1 ip router

Hello again.
Here’s the log from the OH2 where the KNX binding are in debug mode… I can’t find the “Reliable Communication” in the ABB Router configuration. I attached my router configuration…

How to disable the log for the KNx binding again? It spams my log file :slight_smile:

events.log.pdf (35.1 KB)
openhab.log.pdf (205.8 KB)

:slight_smile:

Enter in Karaf console: “ssh openhab@localhost -p 8101” (password: habopen)
Check log levels: "log:list"
Set KNX to Error: "log:set ERROR org.openhab.binding.knx"
Set Calimero to Error: “log:set ERROR tuwien.auto.calimero

Your log looks good. You can safely ignore the warnings.

BR,
Dim

OKay… Thanks :slight_smile: