Knx connection error - yet it is working

I had to recover from a server crash and set up oh2 from scratch and copied my settings from my backup.
Now I have the odd behavior that the log is flooded with error messages (see below) but the knx connection is working fine.
Anyone know what is going on? makes it hard to read the log in case of a real problem (which I still have)

     [                ] - KNXnet/IP Tunneling communication failure on connect Die angeforderte Adresse kann nicht zugewiesen werden (Bind failed)
        at Method)[:1.8.0_144]
        at org.openhab.binding.knx.internal.connection.KNXConnection.connectByIp([191:org.openhab.binding.knx:1.9.0]
        at org.openhab.binding.knx.internal.connection.KNXConnection.connect([191:org.openhab.binding.knx:1.9.0]
        at org.openhab.binding.knx.internal.connection.KNXConnection$[191:org.openhab.binding.knx:1.9.0]
        at java.util.TimerThread.mainLoop([:1.8.0_144]

Is the server ip the same as before the crash?

I guess that in knx.cfg


is set to the wrong address.

Same IP - was and is the server IP.
in knx.cfg it is set to localhost.

# KNX gateway IP address
# (optional, if serialPort or connection type 'ROUTER' is specified)

# KNX IP connection type. Could be either TUNNEL or ROUTER (optional, defaults to TUNNEL)
# Note: If you cannot get the ROUTER mode working (even if it claims it is connected),
# use TUNNEL mode instead with setting both the ip of the KNX gateway and the localIp.

# KNX gateway port (optional, defaults to 3671)

# Local endpoint to specify the multicast interface, no port is used (optional)

# Serial port of FT1.2 KNX interface (ignored, if ip is specified)
# Valid values are e.g. COM1 for Windows and /dev/ttyS0 or /dev/ttyUSB0 for Linux

# Pause in milliseconds between two read requests on the KNX bus during
# initialization (optional, defaults to 50)

# Timeout in milliseconds to wait for a response from the KNX bus (optional,
# defaults to 10000)

# Number of read retries while initialization items from the KNX bus (optional,
# defaults to 3)

# Seconds between connect retries when KNX link has been lost
# 0 means never retry, it will only reconnect on next write or read request
# Note: without periodic retries all events will be lost up to the next read/write
#       request
# (optional, default is 0)

do you use knxd?
if not: set that line to the remote IP of the KNX Tunneling interface (which model do you use?)
if yes: make sure that knxd is running (optionally: configure knxd to act as a Router and switch knx.cfg to TYPE=ROUTER)
Also: in OH2 with individual service config files, don’t use the binding name (knx=) in the config file.



ok… check your /var/lib/openhab2/config/org/openhab/knx.config for stale entries

And please…

localIp is not the loop device :wink: I’m pretty sure this won’t work as expected. instead of this, try

If using knxd or eibd, I would prefer ROUTER mode (you will have to change configuration of knxd/eibd for this)

Well, the error magically disappeared… and the knx binding still works fine.
I am actually using eibd compiled a while back and it keeps working fine for me… so no reason to change.