KNX dimmer sliders moving on it's own

Tags: #<Tag:0x00007f616e1c6cf0> #<Tag:0x00007f616e1c6b60>

Hello everyone i am having this problem where if i adjust the slider of the dimmer in the simple ui interface the slider starts to move on its own to the value it is at this moment.
As an example if i put the slider at 70 percent the slider wil move to 20 than 50 an than go back to 70 to stay there.
Does anyone have a fix for this issue?

I suppose you could prevent your device from reporting its state to openHAB as it ramps to its commanded value. Most people want the UI to show actual state though.

1 Like

first of all thanks for answering my post

I think i wil try that, its a shame that it wouldn’t work. But yeah i will just wait for the day that there comes an update to the openhab binding i gues… .

There won’t be a fix in the binding. It’s reporting what your device tells it.

If you find this annoying, you can fix it with a proxy Item and rules. Put a proxy dimmer on your sitemap, not linked to your device. Have a rule trigger from commands to the proxy, and pass them to the real KNX Item. Have it also start a timer for a minute or so, and copy the real Item state to the proxy state. That should hide the truth.

Can you show your code and part of ETS project?

May be your dimmer sends feedback telegrams when it is dimming light. Try to setup in ETS send feedback only after end of dimming.

Bridge knx:ip:bridge [

type="TUNNEL", 

ipAddress="192.168.0.114", 

portNumber=3671

] {

Thing device generic [

    address="0.0.1",

    fetch=true,

    pingInterval=300,

    readInterval=3600

] {

    //Keuken

    Type switch        : AllesKeuken        "Light"      [ ga="0/5/4" ]

    Type dimmer        : Eetkamer        "Dimmer"      [ switch="0/0/7+<0/1/7", position="0/3/7+<0/4/7", increaseDecrease="0/2/7" ]

    //Living

    Type switch        : AllesLiving        "Light"      [ ga="0/0/1+<0/1/1" ]

    Type switch        : Wandverlichting        "Light"      [ ga="0/5/5" ]

    Type dimmer        : Salontafel        "Dimmer"      [ switch="0/0/12+<0/1/12", position="0/3/12+<0/4/12"]

    Type number        : TempWoonkamer      "Temperature" [ ga="<2/1/0"]

    //Slaapkamer

    Type switch        : NachttafelLinks        "Light"            [ ga="0/0/4+<0/1/4" ]

    Type switch        : NachttafelRechts        "Light"            [ ga="0/0/5+<0/1/5" ]

    Type switch        : LichtKast        "Light"            [ ga="0/0/3+<0/1/3" ]

    Type switch        : AllesSlaapkamer        "Light"            [ ga="0/5/1" ]

    Type dimmer        : MainLight        "Dimmer"      [ switch="0/0/9+<0/1/9", position="0/3/9+<0/4/9", increaseDecrease="0/2/9" ]

    Type number        : TempSlaapkamer    "Temperature" [ ga="9.001:<2/2/0" ]

    //Terras

    Type dimmer        : BuitenLight        "Dimmer"      [ switch="0/0/10+<0/1/10", position="0/3/10+<0/4/10", increaseDecrease="0/2/10" ] 

}

}your code goes here

That could be the issue. But i just don’t really know where i can find the setting to change that

Put this in comment and try again. But the main problem can be first of all in ETS Project: your dimmer may be send feedback telegrams during dimming light. Check it! Give screenshots of you project and say model of the dimmer.

This is DMG 2T dimmer of Theben. As you see, it can give feedback after end of dimming process or every 20% during dimming - like in you case.

If you use only slider in OH to control Dimmer - stay only

"Dimmer" [position="0/3/7+<0/4/7"]

For testing - make new thing:

Type dimmer        : Eetkamer        "Dimmer"      [ switch="0/0/7+<0/1/7", position="0/3/7+<0/4/7", increaseDecrease="0/2/7" ]
Type dimmer        : Eetkamer1        "Dimmer"      [ position="0/3/7+<0/4/7" ]

And new item.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.