KNX Dimmer stopped working after migration from 3.4 to 4.1

Hey guys,
I just upgraded from 3.4.4 to 4.1 by doing a complete new installation via openhabian from scratch and importing the backedup OH config from 3.4.4.
Today I realized that all Dimmers are not working anymore via OH Main UI. I can move the slider, but nothing really changes. Well, sometimes, something happens. But not what I would expect :). From 20 times moving the slider around, only 4 times or so I can see related logs regarding the dimmer.

Is anyone using KNX seeing similar things? It worked until 3.4.4 for years now without any issues.
I have defined my things in a file but items were created via main UI.




As I’m on 4.1.0, too, I can not confirm a general issue, my knx dimmers working like a charm (from Main UI as well as from sitemaps)

Glad to hear! How did your upgrade path look like?
Do you have similar configs like me? So using “sets” instead of “increases” for dimming?

A part of a dimmer looks like this:

UID: knx:device:bridge:hagerDim1_1_5
label: DimmerGruppe 1
thingTypeUID: knx:device
  pingInterval: 600
  address: 1.1.5
  readInterval: 0
  fetch: false
bridgeUID: knx:ip:bridge
location: KNX
  - id: ch1
    channelTypeUID: knx:dimmer
    label: Strahler Buffet
    description: null
      position: 5.001:3/5/22+<3/5/27
      switch: 3/5/20

Don’t use a status GA on switch, a channel can only have one status, and that’s the dimmer level, not the switch status.
I’m not sure if the DPT is still necessary, but it was in OH2 for each parameter with more than one GA (just for my system…), so my configuration is still in this format.

The Item:

Dimmer NWoziDimBuffet "Strahler Buffet"  <lightbulb> (gLights,gDimmer,gNEGWozi)   ["Control","Light"] {channel="knx:device:bridge:hagerDim1_1_5:ch1",autoupdate="false"}

So nothing “too special”.

So I removed the reading GA from the switch and also prefixed the position with 5.001. Nothing really changed. I double checked in main UI that the changes from the thing file were ending up there. Actually just tried a restart - no change.

Sometimes the slider works a bit… I can move it back and forth and the light is following, but whenever I reach 0 or 100 it’s seem broken then. If I slide further after that, nothing happens. Sometimes it still works if I hit 0 and slide further. But doing it again breaks it finally. Funny: sometimes after a while “idle” if I retry, it works again - until I reach start or end. Really random behavior.

What was your upgrade path? I guess not many guys switched to 4.1 yet and having KNX.

I can hop in and say the dimmers works just fine on my side same configuration as @Udo_Hartmann . Some Knx dimmers have settings in terms of how the absolute status is send back maybe look into that. A lot of times I see on the forums here all kind of problems related to openhab knx binding and I am using it since version 2 and most problems are in the way of using either ets or openhab or networking.

Thanks for sharing!
Yeah but it worked til 3.4.4 without any issues :D. So there must be something different with the new version. Or the import of the old configs is screwing up (?).

What was your upgrade path?

Well pretty simple stop openhab clear cache then sudo apt upgrade restart and that is pretty much it but keep in mind I was on 4.0.3 before. Even the 3.4 to 4.0 was pretty ok just redid some stuff related to uom.

I see. So I guess also @Udo_Hartmann did also not install from scratch. Maybe it is related to that.
Coming back to the logs that are printed when I usually move the slider:

When it stops working, those logs also stop. So if this is a KNX setup issue, I would expect the logs to still appear (as the state changed in OH), but publishing it to the KNX binding should throw an error or silently fails or so. But just guessing here…

Well, yes and no :slight_smile:
I did an upgrade (which worked fine), but later I rebuilt the whole openHAB machine (I’m running openHAB on a Proxmox LXC environment). I built this new machine from scratch, as I had another issue (unrelated).
As I’m still using text configuration, I simply built the new machine, then copied all files from old machine-openHAB-conf to new machine, but no json configuration was copied :slight_smile:

My dimmers never did fail, so it’s very unlikely that the update introduced an issue here.

So I enabled Web Developer tools on Firefox and can see, that when I move the slider, it sends one request to Openhab with 200 ok for the Dimmer with a payload of “0”.

After that any movement I do with the slider does not trigger any further request to Openhab. That can’t be right. I tried the same with Chrome. I also did the usual SHIFT-RELOAD in FF.
I would say it looks like a UI issue then?

This looks like the same issue: Not able to use OH-Slider anymore after upgrade to OH4 - #6 by JustinG
Same upgrade path I took.

He talked about hue emulation and this is what I can also see here on my dimmer (I already wondered what this is):

How can I delete this metadata? For the others there is “Remove metadata” but for this not.

Can you post your item dimmer config ?

I did above already. Items are created via main UI. Things I have in a file.

Ok grepped through /var/lib/openhab for HUEEMU. NOT funny (in metadata.json):

I am still not used to UI stuff. But indeed I don’t have any metadata but if I add one I can remove it. Show more details qbout your state description?

Hueemu can be related to hue emulation not very sure !

That was it! Somehow the state description is not working anymore, failing the client I guess. If I remove it, it works again. Thank you :D!

dimmer.scale content:


The HUEEMU page:

I need new glasses… the remove button is at the very bottom. So far that I overlooked it :man_facepalming:.