KNX DPT 20.105 HVAC/Aircon Panasonic Etherea and IntesisBox PA-AC-KNX-1i

My air conditioner wants me to set the control mode by using DPT 20.105.

Copy & paste of the manual:

Object # 2
Name DPTHvacContrMode [1byte]
Function 0=Aut, 1=Heat, 3=Cool, 9=Fan, 14=Dry
Description This object is used to monitor the Operation Mode in the AC unit
Access type Read/Write
Data type ID 20.105


  • GA to set the control mode is 7/1/3 (DPT 20.105)
  • GA to get the control mode is 7/2/2 (DPT 20.105)
  • Using the group monitor inside ETS, setting/getting the control mode works fine

In OpenHAB 2.3/knx2 binding it doesn’t work like this:


Type number	: A_EG_AZ_Aircon_setControl "Klima EG AZ Modus einstellen" [ ga="20.105:7/1/3+<20.105:7/2/2" ]


Dimmer  A_EG_AZ_Aircon_setControl     "Klima EG AZ Modus einstellen"                  (Klima)			{ channel="knx:device:tunnel1:AirCon:A_EG_AZ_Aircon_setControl" }


Switch item=A_EG_AZ_Aircon_setControl mappings=["0"="AUTO", "1"="HEAT", "3"="COOL", "14"="DRY"]

In the event.log there is an entry

Item ‘A_EG_AZ_Aircon_setControl’ received command 0

ETS group monitor and GA are not impressed and show nothing, any idea?

I already had a look at this issue and this issue, but don’t have the right idea how to proceed.

Try using Number as item type instead of Dimmer.

I tried this


Number A_EG_AZ_Aircon_setControl     "Klima EG AZ Modus einstellen"                  (Klima)			{ channel="knx:device:tunnel1:AirCon:A_EG_AZ_Aircon_setControl" }

1st result: Same issue, ETS doesn’t realize anything from OpenHAB regarding get/set
2nd result: After restarting OpenHab, I see this in OpenHab when clicking through the control modes. Still the device doesn’t react.

I’m wondering about the most right column “Info”. Compared with manual setting/getting control mode, the values have a “$” sign and show the right DPT 20.105:

50% are working - air conditioning control mode can be chosen via selection menu and is sent correctly to the device.

Looks like this:

openhab.log //when I make a selection
 Wrote value '0' to datapoint 'command DP 7/1/3 'knx:ip:tunnel1', DPT id 20.105, low priority' (0. attempt).

Type	string: A_EG_AZ_Aircon_setControl "Klima EG AZ Modus einstellen"[ ga="20.105:7/1/3+<7/2/2" ]

String  A_EG_AZ_Aircon_setControl     "Klima EG AZ Modus einstellen" (Klima)	{channel="knx:device:tunnel1:AirCon:A_EG_AZ_Aircon_setControl" }

Selection 	item=A_EG_AZ_Aircon_setControl mappings=[0="AUTO", 1="HEAT", 3="COOL", 14="DRY"]

Updating the item with the current state fails. A few seconds after chosing an entry, the selection is blank.
In ETS everything is fine, KNX GA 7/2/2 can be read and pushes the state on the bus:

Thing 'knx:device:tunnel1:AirCon' received a Group Write telegram from '1.1.19' for destination '7/2/2'

2 questions:

  • How can I debug the actual state of a DPT of the Group Write telegram? In DEBUG mode, I only see the linke above
  • Any idea how to get the updated GA back to the selection?

This procedure may help me, I’m trying on and on.

Seems there is a problem with DPT 20.105, in the KNX definition it is a Byte, in openhab it seems to be a String.

Yes I had the same issue, had to trick it.
Im using KNX 1 not 2, but the same trick should apply, in ETS leave the setting u are using, but in OH configure the GA using 5.004 instead, with dimmer as an item. Since you are in KNX 2, try using string
This is my settings

Dimmer          FF_GuestRoom_AC_Mode        "Mode [%s]"                      {knx="5.004:1/6/27+<1/6/31"}

and on sitemap>

Switch  item=FF_GuestRoom_AC_Mode mappings=[0="Auto", 1="Heat", 3="Cool", 9="Fan", 14="Dry" ]

I think I finally have a solution in OH2

There following issues appeared

Issue #1 - Dealing with DPT 20.105
Frank explained the way how OH treats DPT 20.105. Different than expected.

Issue #2 - ETS5 device configuration
It´s a generic application, so I had to find out the proper configuration of my air conditioning system. E.g., Indoor unit has fan mode=no". Tested it out by writing and then reading the mode, for instance. I also tested mode settings with the remote control.

Issue #3 - Bus reply strings are not identical to Intesis handbook
My air conditioning system should theoretically have a mode “Dry” and exactly use this string. But it used “Dehumidification” instead. Took a while to understand, why a sent out mode didn´t show up in the sitemap selection.

My solution looks like this for interface

Panasonic Etherea AC units to KNX Interface with Binary Inputs - 1 unit
PA-AC-KNX-1i, 4 binary inputs
new Item #INKNXPAN001I000



Thing device AirCon_EG_AZ "Klimaanlage EG AZ" [
        ] {
            Type string : A_EG_AZ_Aircon_ControlMode "Klima EG AZ Control Mode" [ga="20.105:7/0/3+<7/1/2"]


String A_EG_AZ_Aircon_ControlMode "Klima EG AZ Control Mode" (AirCon_EG_AZ) {channel="knx:device:tunnel:AirCon_EG_AZ:A_EG_AZ_Aircon_ControlMode"}


Selection item=A_EG_AZ_Aircon_ControlMode label="Aircon Control Mode [%s]" mappings=[Auto="Auto", Heat="Heat", Cool="Cool", Dehumidification="Dehumidification"]