KNX heating/cooling item

Hi there

I have an issue with one of my items, though I’m not sure whether the knx Binding actually covers this.

The use case: our heating also serves as a cooling, but we have to manually switch it via knx. Therefore, I have set up a knx channel (in my knx things description):

	Type switch :  Kühlung "Kühlung" [ ga="<3/4/0" ]

Switching this on/off works fine - I can see that in the bus monitor for knx.

However, in the sitemap/page the changed state is not persistent, i.e. if I switch the item on and then leave the page/sitemap and go back again later, the switch looks to be off.

Could that have to do with the data type? It’s a rather uncommon one, 1.100
Would it help to put in the data type into the things definition?

Just for info: all other “knx switches” (with other datatypes) work perfectly fine and as expected.


You don’t need to set the correct DPT here (knx bus does not differ between sub-DPT). But a question:
Did you restart openHAB after setting up the UI/Channel/Item…?

Yes, that was the first thing I tried after setting up the item, restarting OH.

Maybe another issues comes into play here, though I’ve never had any issue with this before:

I have an KNX IP Gateway set to Tunnel. The KNX device, however, was converted using the GitHub project from @jo47011 - the knx file generates a thing with the adress 0.0.0. Meaning I only have one knx thing with all the GAs as channels in there. This thing is always offlinem but I can still control and see/read the values of every channel/item.

Is this the Bridge or is it the generic thing?
The former is ok, the latter is completely wrong, as a generic knx Thing, representing the whole bus but not a single device must not have any address (i.e. “individual address” in english or “physikalische Adresse” in german).

Hi Udo
thanks, that did it! Let’s see whether this might also change some other weird behaviour I have seen with the KNX binding.

Thanks again.