KNX - How to display DataPointTypes correct in OpenHab

Hi Everybody

The Basic functionality (switches) with openhab works fine and I’m impressed by the simplicity of the configuration (until now :slight_smile). I’m using the 1.8.1 (and checked the change log for 1.8.2 about DataPointType issues etc.).

I’m trying to display values from the KNX Bus in Opemhab.
To verify the displayed values, I have a ProServ running in parallel (and of course the ETS5 Monitors).
I tried to get proper results with different DataPointTypes without luck :sweat: This implies i have missed something fundamental.

Here the sample:

ETS5 Monitor:
RawData «29 00 BC E0 11 46 01 F3 05 00 40 3E 9C D1 75»
DataPointType «14.019»
DecodedDpValue «3E 9C D1 75 | 0.3062855»
RawDpValue «3E 9C D1 75»

Correct display on ProServ:
«0.3062855 A»

Incorrect display on Openhab:
«2165.7600 A»

Here the extract of «default.items» regarding the 0/1/243:
Number Bus_A “KNX Bus [%f A]” (Energie) {knx = “<0/1/243”}

As this is a rainy Sunday, does is anybody has a hint, what i have to check, change or add :wink:
Please tell me if i have to post additional files (or extracts).

A generic procedure will also be fine for me (and all other beginners)…
Thank you so much for all the support…


Did you try to set the dpt?

Number Bus_A "KNX Bus [%f A]" (Energie) {knx = "<14.019:0/1/243"} 
1 Like

Thank you Udo!
It works perfect by adding the DataPointType before the «Gruppenadresse». :smile:
But what shall be used for a «14.* 4-Byte Gleitkommawert» in the «default.items» (i.e. if the units proposed by the ETS5 do not fit {e.g. [dl/h]})?
KR Urs

As far as I know, the minor DPT isn’t that important for correct data, as the units do no exist in openHAB at all. The main thing is to set the correct major DPT.

It seems that not every DPT available in ETS5 works with openhab 1.8.1.
As it is unpredictable which DTP works I use «.001» (e.g. 14.001) as a workaround.
Thank you for your Support Udo. It solved my issue!