[KNX] I can add a controller, but no Device

  • Platform information:
    • Hardware: BeagleBone Black 512MB RAM
    • OS: Debian Linux 10.0
    • Java Runtime Environment: java version “1.8.0_181”
    • openHAB version: 2.4.0-1
  • Issue of the topic: KXN Device stays offline, error in logs
  • Please post configurations (if applicable):
    • Items configuration: not yet created
    • Sitemap configuration: not yet created
    • Rules code: not yet created
    • Services configuration: not yet created
  • If logs where generated please post these here using code fences:


I am quite new to OpenHAB, but not to linux. So, I installed OpenHAB via apt (on my BeagleBone) and started it. I followed the New User Tutorial with the Network Binding and then tried to add a KNX Binding. This worked also well - my Controller (the same computer) is online and visible.
But then I tried to add a KNX Device, an actor-controller. I filled all the configuration details, but device stays offline.

in the log I find this:

2019-09-10 14:27:48.507 [ERROR] [ome.core.thing.link.ThingLinkManager] - Exception occurred while informing handler: null java.lang.NullPointerException: null
        at java.util.Objects.requireNonNull(Objects.java:203) ~[?:?]
        at org.openhab.binding.knx.internal.handler.DeviceThingHandler.getChannelTypeUID(DeviceThingHandler.java:252) ~[?:?]
        at org.openhab.binding.knx.internal.handler.DeviceThingHandler.isControl(DeviceThingHandler.java:246) ~[?:?]
        at org.openhab.binding.knx.internal.handler.DeviceThingHandler.channelLinked(DeviceThingHandler.java:138) ~[?:?]
        at org.eclipse.smarthome.core.thing.link.ThingLinkManager.lambda$0(ThingLinkManager.java:300) ~[?:?]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180) [?
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293) [?:?]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
        at java.lang.Thread.run(Thread.java:748) [?:?]

what am I missing here?

Would you show us these?

Thanks for that question - the address was wrong. I had 1.1.0 instead of 1.1.33. As soon as I changed that I was able to create channels and go on.

Thanks for that hint!

1 Like