KNX OH 4.0.0 M3 oh_slider_item losing the position


I have a problem with the slider. I want to use the slider item to set the blinds.
The config is: Type → Dimmer and Semantic Class → Point.
With 3.4.2 it works perfectly, but with OH 4.0.0 M3 the slider is losing the position after showing it again. If the item has the focus it works and the thumb updates the position. But if I close or change the window and I go back to the item the thumb is always positioned at zero.

Any ideas?

PR `oh-slider` & `oh-knob`: Fix user configured unit (state description) ignored by florian-h05 · Pull Request #1920 · openhab/openhab-webui · GitHub should have fixed this, it was a regression from previous PR `oh-slider`: Fix command sent on state update due to rounding by florian-h05 · Pull Request #1894 · openhab/openhab-webui · GitHub.

The regression made it into openHAB 4.0.0.M3, the fix not, but luckily today a new milestone will be released with the fix (approxy. 6 pm CET I think), so please try out openHAB 4.0.0.M4 once it is released.
Please note that you probably need to reload the UI from the „Help & About“ page.

If the problem is solved, please mark this post as solution.

Many thanks, now it works again! :+1:

1 Like