KNX serial port AMA0

Hi, I tried to connect my raspberry to the knx through an IC00R01KNX.(the device software works). I setted the port to be disabled , added the row in the script but the message still is:
Error connecting to KNX bus: Serial port ‘/dev/ttyAMA0’ could not be opened

in the configuration file:

there is a way to do openhab open this port?
thank you

Assuming you installed using apt-get, add the openhab user to the dialout group.

and ensure you are not putting the

to the end of the java line. Just after -Dosgi.noShutdown=true otherwize it will not work either,


Thanx for the responses guys, but the error perstists. Others ideas?
There is a way to read the feedback terminal dialog during the apt-get version execution as in the normal way with thank you!

All logs are stored in /var/log/openhab.

To see what scrolls by when you start openHAB using run:

tail -f /var/log/openhab/openhab.log

Thank you now I have seen that the problem is the same:
Error connecting to KNX bus: Serial port ‘/dev/ttyAMA0’ could not be opened
I don’t understand, I have done all what I had to do:

  • disabled the serial port AMA0
  • installed openhab through apt-get install
  • installed the boundles knx and serial and configured the serial communication with the port ttyAMA0
  • inserted ‘openhab’ in the dialout group
  • added the row just after -Dosgi.noShutdown=true

What I am missing?

Just for kicks and to put to bed the problem being a permissions problem change the permissions on /dev/ttyAMA0 to full read/write. The permissions will only stick until the next reboot which is why adding the openhab user to the dialout group is preferable.

The command is:

sudo chmod a+rwx /dev/ttyAMA0

Then restart openHAB and see if the error goes away. If it does then we know it is a permission problem. If it doesn’t then there is some other problem, perhaps the serial device is not working or something like that.