KNX - The light switches itself on

I have a raspbery pi configured with a knx usb interface.

Openhab 2 it working well, but sometimes the lights itselfs turn on.

I not have any rule configured.

Has anyone ever had this problem? Can someone help me?


Maybe you have set some GA in your devices the wrong order, so openHAB requests a state and another GA will answer (which will cause another channel to switch to the state) - I’ve had this issue, which would only take place when a home automation is started (not necessarily openHAB).

@Udo_Hartmann what is GA?

GA = GroupAddress

This is an essential part of knx communication. Are you sure that you know what you are doing?


I have many GA configured. And I not know how debug this problem.

In your opinion, the problem can not be from OpenHab… then it could be from KNXD, did the communication between Openhab and KNX devices.

Typically the same light goes on every night at about the same time.

What do you mean by this: “Maybe you have set some GA in your devices the wrong order” ?

The problem does not occur when home automation is started, and does not occur when start Openhab.

Udo I don’t use Knx, so I was unfamiliar with terms. I read the thread and was asking for curiosity and understanding.


Ah, sorry, didn*t look at the Name… :smiley:

1 Like

Well, if you did not set up any rules, (and did not set up any other timing mechanism for knx bound Items) why should openHAB send commands to knx?

In fact, I have two openHAB systems up and running (OH1.8 + OH2.4) at the same time, both are bound to knx, and I see no irregular switching at all. So yes, I doubt that openHAB is the source of your problem.

In question of knxd, as I don’t use knxd, I can’t say there is no problem, but to be honest, there are quite a few people out there which use knxd in combination with openHAB1 and/or openHAB2, it’s unlikely that your problem would be unique.

To debug this problem, I think there are two options.

  • Option 1 is to set the openHAB knx binding to DEBUG log. But it’s not that easy, because there is quite some output from knx on debug level, so it would be best to use an extra log file, and this is the “not so easy” part.
  • Option 2 is to start the knxd group monitor in background to see the knx communication (and get information about the source of the commands)