KNX Thermostat setting

A question on KNX…I’ve got all my KNX lighting working really well via openhab and google home…Status & Switching. I’ve also got my thermostats being read too.

Now, I want to go a little further with the Thermostats and try to set them. Is this possible? Anyone had success setting the target temperature? I assume I need to expose more of the GAs for the devices that I need to set the target temperature for.

@Dim - I know you are good at this stuff :wink: any ideas?

You will need to adress the temperature in and output of your KNX device this is normally a temperature data type.


Type number        : Temperature_GF_gang    		 	    [ ga= "9.001:<4/0/12" ]


Number Temperature_GF_gang  		"Temperatuur gang BG [%.1f °C]" 		<temperature>	(Temperature, GF_gang)	                            { channel="knx:device:bridge:generic:Temperature_GF_gang" }


Setpoint item=Temperature_GF_gang		 label="gang [%.1f °C]"		 				step=0.5 minValue=15 maxValue=24

thanks Mark, will give that a try

So @Zijl which KNX address do you think should i reference for my Gira temp unit? I have:

currTemp - 2/1/0
setTemp - 2/1/6
status - 2/1/5

? Or maybe there is another one? Prob need to dig out the addresses from ETS4


Thinking about it, it’s got to be the setTemp

replying to my own posts now :wink: Is that the first sign of madness :stuck_out_tongue_winking_eye:

And YES - that’s working perfectly!!! I can move the temp up and down and the new values appear on my Gira app and the screen on my temp switches on the wall - nice one! Thanks @Zijl

Only think is it doesn’t show the current status (ie, temp). I think i may be missing something to get the current temp back when I re-load the items map. It seems to take a very long time to update the temperatures.

If it does sent back on the setTemp ga, you need to check if the read flag is set in ETS. If not, you can reference more than one ga in OH: ga= “9.001:2/1/6+<2/1/5” for example.