KNX2 - problem reading property (response 43 d6 00 01 00 00)

Hi there,

just wanted to ask if there’s a solution for this issue. It does not affect working with KNX2-binding, but it fills up my openhab.log once approximately 4-8mins after OH2 init/reboot. In the log there are between 80 and 130 occurances that are written in between 3 and 5 seconds within OH2’s runtime.

First (common) entry in the log-file;

2018-09-25 11:01:51.152 [INFO ] [egram.internal.TelegramActionService] - Bot [XXX] loaded from config file

As all log-entries are the very same (I’ve compared them punctually with Notepad++) I’m going to just attach the very first;

11:07:30.333 [WARN ] [calimero.mgmt.MC [GATEWAY-IP]:3671      ] - problem reading property (response 43 d6 00 01 00 00) property access OI 0 PID 1 failed/forbidden
	at ~[?:?]
	at$readProperty$0( ~[?:?]
	at ~[?:?]
	at ~[?:?]
	at ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInfoClientImpl.lambda$2( ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInfoClientImpl.readFromManagementClient( ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInfoClientImpl.readDeviceProperties( ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInspector.readDeviceProperties( ~[?:?]
	at org.openhab.binding.knx.internal.client.DeviceInspector.readDeviceInfo( ~[?:?]
	at org.openhab.binding.knx.handler.AbstractKNXThingHandler.describeDevice( ~[?:?]
	at org.openhab.binding.knx.handler.AbstractKNXThingHandler.lambda$0( ~[?:?]
	at java.util.concurrent.Executors$ [?:?]
	at [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201( [?:?]
	at java.util.concurrent.ScheduledThreadPoolExecutor$ [?:?]
	at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]
	at java.util.concurrent.ThreadPoolExecutor$ [?:?]
	at [?:?]

What I’ve done so far; I found a post of @Udo_Hartmann at Problem reading property so I’ve set all DPTs in my .things-file but the warnings still appear in the log.

For example, here’s the rollershutter right next to me;

Type rollershutter : Channel_J1_04 "Channel J1.04 - OG / Büro / Fenster Ost" [ upDown="1.008:3/2/80", stopMove="1.010:3/2/81", position="5.001:3/2/82+<3/2/86" ]

Also, I double-checked that all channels on my actuators, that are read by OH are actually read-able.

Anyone else facing/faced that issue? Many thanks in advance & BR,

disable fetch in the Thing to get rid of this warning
It seems that some KNX Actuators do not support (or allow?) “fetching”, so if you try to read their parameters, you will get this warning in openhab.log

Hi @Dim - first of all, I’m very sorry that I didn’t reply earlier (just saw the notification while browsing through forums)!

According to your hint, I removed the [fetch=true] setting from all my actuator-things. After some hours of uptime and oh2-service-restarts I can safely say that this was the issue that caused the error-log to fill up.

Many thanks for your help and merry christmas to you :)!


1 Like