Leviton Vizia RF+3 (VRCS4) Scene Controller - not sure how to set up


(Richard Bergen) #1

Hey guys,

I’m at a loss as to how to configure this scene controller. I have it associated through HABmin (Paper UI throws errors), but I don’t see any channels in HABmin.

After it is associated though HABmin, when I go into Paper UI, it shows that there is a channel already linked called “scene_number”. Seems to be a conflict and I’m not sure which one is right.

When I push buttons on the scene controller, I don’t get any logs showing up in events.log though like I normally do with other zwave devices. Since there are no logs showing up, I don’t know what to do.

Does anyone have any pointers for me? Since it is online, it looks like it should work, but I don’t know what to do next.

thanks
Richard


(Mark) #2

Is HABmin showing no channels, or is it showing that there are no items linked to the channels? If the latter, you may be seeing the symptom of a HABmin bug. Refresh the page and it should show the linked items.

You could try putting the zwave binding into debug mode and check for activity in openhab.log when you press buttons on the device.

The database entry for this device was updated pretty recently. What version of openHAB are you running? If you’re on 2.3, it might make sense to upgrade to 2.4 M5 or a recent snapshot version. Be advised, if you are on 2.3 and you do upgrade, please read the post on changes to the Z-Wave binding.


(Richard Bergen) #3

Sorry, HABmin is showing a channel, but nothing is linked. In Paper UI, it is showing as linked though.

I’ll try to figure out how to debug zwave and I’ll post the results.

I’m running 2.3 right now, but I’m running a dev zwave snapshot to support secure zwave. Looks like that’s included in 2.4 anyway.

213 │ Active │ 80 │ 2.4.0.201809081506 │ ZWave Binding

I’ll try upgrading to 2.4 and see what happens. Thanks for the reply!


(Richard Bergen) #4

Ok, I managed to upgrade to 2.4 and enable debug on zwave. I do see logs when I press the buttons. Here’s the output on a single button push:

2018-11-09 22:08:01.407 [DEBUG] [WaveSerialHandler$ZWaveReceiveThread] - Receive Message = 01 15 00 49 84 13 0F 02 01 00 85 2D 7C 77 82 73 86 72 91 EF 2B 2C E7
2018-11-09 22:08:01.424 [DEBUG] [nal.protocol.ZWaveTransactionManager] - processReceiveMessage input 0<>128 : Message: class=ApplicationUpdate[73], type=Request[0], dest=19, callback=132, payload=84 13 0F 02 01 00 85 2D 7C 77 82 73 86 72 91 EF 2B 2C
2018-11-09 22:08:01.430 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Received msg (0): Message: class=ApplicationUpdate[73], type=Request[0], dest=19, callback=132, payload=84 13 0F 02 01 00 85 2D 7C 77 82 73 86 72 91 EF 2B 2C
2018-11-09 22:08:01.435 [DEBUG] [nal.protocol.ZWaveTransactionManager] - lastTransaction null
2018-11-09 22:08:01.438 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Checking outstanding transactions: 0
2018-11-09 22:08:01.441 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Last transaction: null
2018-11-09 22:08:01.447 [DEBUG] [ve.internal.protocol.ZWaveController] - Incoming Message: Message: class=ApplicationUpdate[73], type=Request[0], dest=19, callback=132, payload=84 13 0F 02 01 00 85 2D 7C 77 82 73 86 72 91 EF 2B 2C
2018-11-09 22:08:01.450 [DEBUG] [essage.ApplicationUpdateMessageClass] - NODE 19: Application update request. Node information received. Transaction null
2018-11-09 22:08:01.453 [DEBUG] [ng.zwave.internal.protocol.ZWaveNode] - NODE 19: resetResendCount initComplete=true isDead=false
2018-11-09 22:08:01.457 [DEBUG] [essage.ApplicationUpdateMessageClass] - NODE 19: Application update - no transaction.
2018-11-09 22:08:01.460 [DEBUG] [nal.protocol.ZWaveTransactionManager] - ZWaveReceiveThread queue empty
2018-11-09 22:08:01.464 [DEBUG] [nal.protocol.ZWaveTransactionManager] - Transaction SendNextMessage 0 out at start. Holdoff false.

I don’t see any items in the events.log though.

I did remove all z-wave things after I upgraded to 2.4 as indicated by the documentation and re-added all of them. Also tried excluding and re-associating the scene controller again.

Am I missing something obvious?


(Mark) #5

Try refreshing/reloading the page in HABmin. That usually causes the links to reappear.

This isn’t what I would expect from a button press. I would expect to see a SCENE_ACTIVATION command class. Are you sure you included the right snippet from the log.

The above image is from the Z-Wave Log Viewer, a handy tool for visualizing what’s in the log. Perhaps you can try viewing the entire log to see what’s going back and forth between the device and the binding.
https://www.cd-jackson.com/index.php/openhab/zwave-log-viewer


(Richard Bergen) #6

Thanks, when I refresh HABmin, I do see “Scene Number” attached to it, like I do in Paper UI.

When I ran the existing debug logs through the tool, that’s all I saw in there - UPDATE_STATE_NODE_INFO_RECEIVED.

Maybe what I’ll do is exclude, keep it in debug and then include those logs as well. Thanks for the heads up on the log viewer tool.

Stupid question, but the buttons are not mapped to scenes, since I don’t see a way to do that within the binding for the thing. Is that maybe why I’m not seeing any SCENE_ACTIVATION commands? I also don’t see in the documentation on how to do that, as well as searching for VRCS4 examples in the forums.


(Mark) #7

I’m not very familiar with this device, but I suppose you could try setting Association Groups 1-4 to your controller node (node 1).


(Richard Bergen) #8

I was away for a while and finally had a chance to look at this. When I set each group to “controller”, it seemed to fix the issue.

2018-12-05 20:35:24.697 [vent.ItemStateChangedEvent] - zwave_device_512_node21_scene_number changed from 4 to 3
2018-12-05 20:35:30.014 [vent.ItemStateChangedEvent] - zwave_device_512_node21_scene_number changed from 3 to 2
2018-12-05 20:35:32.943 [vent.ItemStateChangedEvent] - zwave_device_512_node21_scene_number changed from 2 to 1
2018-12-05 20:35:39.044 [vent.ItemStateChangedEvent] - zwave_device_512_node21_scene_number changed from 1 to 4

Thank you very much for your tip!