LG ESS Enervu Binding [4.1.x]

This binding connects to the LG ESS Enervu service either via cloud(https://enervu.lg-ess.com) or directly via local REST-API and provides all readings available from the official app as well as some confinience trigger channel.
The binding is compatible with OpenHAB 3.1 and later.

  • Autodiscovery of the local powerrouter is supported
  • Data for current / daily / monthly usage is supported
  • Trigger event when produced power is above a configured threshold is available
  • Trigger event when battery SOC is below a configured threshold is available
  • Trigger event when battery SOC is fully charged, at low battery state or fully depleted available

For more information please see the Documentation


Version 1.0

  • initial release on marketplace

Version 1.2


openhab 4.1.0

Source code

1 Like

Hello, I tried to install the binding via the standard Add-On functionalitiy but got the message

Installation of add-on marketplace:146834 failed

Do I have to install it the pedastrian way…?

Not sure what version of openHAB you tried installing the binding. But the binding is not compatible with 4.x.x.

I’m on 3.4.4… when I try to install I get this

and afterwards the error code reported above…

The url in the topic is wrong. It points to the GitHub page, but it should point to the jar file directly. @SkyRaVeR in general it’s not needed to put jar files in a repository. Just create a release on GitHub and attach the jar file to that release and put the url to that release here in the topic.

@humus2002 If you want to test, before the url is fixed in this topc, it download the jar file and put the jar file in the addons folder.

thx for the advice, unfortunately it is not working… I copied the .jar to the path /usr/share/openhab/addons file using

sudo wget openhab-lgessenervu-dist/org.openhab.binding.lgessenervu-3.4.3-SNAPSHOT.jar at main · mksway/openhab-lgessenervu-dist · GitHub

but again, when trying to add a new thing using the openhab GUI , the LG ESS is not offered as a binding…


sorry for the long delay to answer.
I created as suggested by hilbrand a release and put this url here in the “resources section” instead of the old one.
Since I am a struggling with git and the structure at all I don’t know exactly if it’s working or not.
Currently still the binary repo is referred but I will move to the source repo with a release in the near future (didn’t know about the release binary thing there)

After changing the urls i just tried it with a fresh openhab install and installed it from the marketplace myself and it’s magically working.
Though I noticed that it downloaded the version 3.4.3-snapshot and I run 4.0.1.
Looks like the binding works with 4.0.1 as well - at least it discovered my powerrouted automatically.

@hilbrand One short question - do i need to open a thread for each openhab version or how does openhab marketplace know which file to install?


:grinning: - fantastic - the thing is up and running right now, I could download & install the binding successfully…

I upgraded from openhab 3.4.4 to 4.0.3 by setting up the system from scratch and then I migrated my old configuration to the new system
initially (when restarting, doing a pseudo change in the LG-thing) the values are updated in the corresponding items of the channels but only once - no continous updates
I removed and installed the binding again - no success
any idea what could be wrong?

i switched to 4.0.4 yesterday and had the same issue. some cast failed :frowning:
Since I just recompiled it for 4.0.4 it looks like something changed in the “underwear” of openhab.
I recompiled the code and now it’s working again.

After upgrading to openHAB 4.1 (via new installation) I was very happy to find the LG ESS Plugin in the marketplace. Everything worked great until I found out, that the values are not updated. It seems to be the same problem humus2002 has. If I change something in the configuration of the plug-in, e.g. make a new link to a channel, I get a value but no further updates.
Any idea, what might be the problem or what I can do?

Thank you!