"LG TV Binding" with WLAN on LM860?

Hi all,

Is it valid that the LG TV Binding (https://www.openhab.org/addons/bindings/lgtv1/) is only working via LAN (eth) and not via WLAN (wifi)? At least this is what i observe on my side.

I would have assumed that it shouldn’t matter which network interface I am using. Or is this a matter of my LG TV (LM860 series)? I don’t find much of information on this TV for Netcast and what it supports.

Thanks for any hints or clarification on my issue.

It’s probably more about your network. Does your openHAB host have both wired and WiFi? Same IP domain?

Yes, Openhab is running on a RPI3 with wifi and eth.
And all my devices are in the same network domain.

Is there a way to define the network interface which shall be used by openhab2?
How should the sender affect my the TV to reacte on the one network but not on the other?
At least the logs from Kodi show that the request is send out to the TV, but the TV seems to not react on this request.

I never got the LG Binding to turn on the TV, it turns it off just fine, but not on (wired, ethernet connection)

I installed the Wake On Lan Binding and got that to turn on my LG (OLED55B7). I also had to turn on the LG Connect Apps function under the Settings menu in order for this to work.

1 Like

Thanks for you reply, as my TV is “quite” old it is not yet runing webOS but only netcast. Therefore i need to use the “older” binding as listed above. I understand that the LT TV Binding uses an IP based request to turn of the TV but this interface is no longer runnning if the TV is powered off. Therefore I also tried to use WOL for wakup. But neither on LAN nor on WLAN I am able to wake up the TV.

Maybe netcast TVs do not yet support WOL?
Looks like my TV is a little to old for OpenHAB? Or does anyone have more hints for me how to solve it?

Something I tried, before I got it to work with Openhab, was I installed a WOL app on my phone and tried turning the TV on using that. Once that worked, it gave me confidence that I could get it working in OH. Lots of WOL apps out there for phones/computers that you can try.

1 Like

Hi, thanks for that hint. I had the same thoughts and did try it with apps, but no success yet.
Currently I am doubting that my LG supports WOL or that WOL is blocked by my router (which is also my ETH switch for now)

Did you have a LG TV and if yes, which OS is it running? Netcast or WebOS?

Do you send the WOL request (Magic packet) to ETH or to WLAN?
I read some posts in other formums that it might be required to send the WOL to both WLAN and ETH, but also this did not solve my problem.

I’ve never seen a setup where a magic packet works to a WLAN device, only Ethernet in my own experience.

If you own a laptop or desktop computer you can activate WOL in the BIOS, connect the device to your network via a network cable and then send a WOL packet to the laptop / desktops ETH MAC address from your phone. If your computer turns on, then your switch is fine and is not blocking the packet

1 Like

Hi Nears,

Not sure if this is still your main question but I can confirm that the binding also works using WiFi.
As of today, i switched from ethernet to wifi. Works in both
As I only use Kodi (with CEC) I can turn on the TV. I am not too sure if this binding allows you to power on the TV aswell.

Looks like you are using the LG Web Os binding which is not the one I am using, as my LG TV still runs on Netcast OS (old) but not on WebOS (new).

okey sorry my bad!

Thanks for that hint… don’t know why I didn’t thought of it before :blush:
I tried to wake-up my RPI attached to ETH from a android app and from OpenHAB (running on another PI) connected to ETH, but both ways did not wakeup my PI. Therefore I would assume that WOL is not supported by my router. :frowning:

The Raspberry Pi itself cannot be woken using WOL. You’d need to wake a laptop or desktop (which has WOL enabled in the BIOS)

https://www.raspberrypi.org/forums/viewtopic.php?t=205464