LG TV - no pairkey defined


I’m using the LG TV Binding on OpenHab2.
I’m unable to pair my TV with OpenHab.
I’m getting the message:

2017-02-22 00:10:38.003 [ERROR] [binding.lgtv.internal.LgtvConnection] - no pairkey defined

Sometimes I also get:

2017-02-21 23:30:52.150 [ERROR] [binding.lgtv.internal.LgtvConnection] - sendtotv but connection status is CS_NOTCONNECTED
2017-02-21 23:30:52.153 [ERROR] [binding.lgtv.internal.LgtvConnection] - IO Exception at Connection to:
2017-02-21 23:30:52.153 [INFO ] [binding.lgtv.internal.LgtvConnection] - sendpairkey with result=#error/connect-1 connectionstatus=CS_NOTCONNECTED

I don’t understand what I am doing wrong.
This is my LG TV config:

# The ip address of the lgtv (required)

# The TCP port to use (optional, defaults to 8080)

# The the pairkey / if it's wrong the device shows the right pairkey
# at every connection attempt

# The TCP port address of the openhab system to receive lgtv status messages
# (only first occurrence is used for all TVs)

# The location to put XML files with the information of availiable
# channels and apps (optional)

# The check alive interval (optional, defaults to 60secs)

As you see, the pair key is empty.

However, I don’t see any pair key on my TV screen.
The IP address is correct.
“LG Connect Apps” is turned on.
I have already stopped pairing on my TV. When I launch the LG-app on my Android, the TV displays a 3 digit pair code I need to fill in on my phone. So this part of the process is fine. However, I never get a 3 digit code triggered by OpenHab.
The software version of my TV is 04.25.55
My TV is a LG 43UF680V.

Hello! I have 2 TV LG. One with WebOS, second to none. That’s what a WebOS, I, too, was unable to connect. I think this is the problem. Your with WebOS?

Yes, my TV has WebOS.

The firmware is 04.25.55. I think it is WebOS 3.0, but could also be WebOS 2.0.

I was able to solve it!

I used the new ConnectSDK Binding:
Download from:

Save it in the add-ons folder.

Read wiki:

I received a pairing request on my TV. I just did some quick config, and was able to mute my TV.


Thanks for the info. I tried to connect did not work, I WebOS 1.4 Later on, I will try another may succeed.

I’m not getting a proper connection, also each time in my logs: ‘no pairkey defined’, what’s normal since I don’t know it yet.

I’m having a LG Oled TV with webos 4.31.10.
But it seems that I don’t have anything listening on 8080?

nmap -Pn

Starting Nmap 6.40 ( http://nmap.org ) at 2017-05-18 18:00 CEST
Nmap scan report for oledus (
Host is up (0.00066s latency).
Not shown: 995 closed ports
1524/tcp open  ingreslock
1600/tcp open  issd
3000/tcp open  ppp
3001/tcp open  nessus
9998/tcp open  distinct32

Any idea if if must activate an option somewhere?

Hi Ben,

Don’t use the standard LG TV binding. I never got it to work.

There is a great alternative binding developed by @sprehn, it is just not official yet.
Check out this topic:
Binding download link:

Good luck,

Sorry for the (very) late response.
I’m trying the links your gave, and it looks promising.
Some issues with my items, but discussing it in that topic.


Pair key problem solved!
Just input the pair key as shown with 6 digits on the tv and restart openhab.
This solved the problem and let me connect to it.

bought in November 2013. Model: LG 50LA6208 3D. Making always updates. once a month.


silly question from a beginner
So far: configured lgtv.cfg and seems that it connects OK to LG TV LA6918:
“[INFO ] [binding.lgtv.internal.LgtvConnection] - sendpairkey with result=200 successconnectionstatus=CS_PAIRED”
Also defined lgtv.items and these are displayed in PAPERUI, e.g.
“Switch LgTvPower “Power Command” (GF_Living) {lgtv=“ON:lgtvId1:POWER”}”

The Thing is however not displayed - Is that OK?

Question: what to do next? How to execute a defined command? How to test the item?
Thanks a lot!!