LG WebOS Binding

Dear Community

I use the LG WebOS binding for my LG OLED TV.
But suddenly the connection stopped working.
I can now only switch on via WOL, but no longer operate anything.

The device always shows the status “TV is off”, so OpenHAB thinks the connection is ok.
Now I don’t know how to pair the TV again.
Even if I enter a random IP address, the device remains in the “TV is off” status and does not notice that there is no longer any connection to the tv.

I’ve also tried deleting and re-creating the device. But even then I can enter any IP address and the status always changes immediately to “TV is off”.

I assume that a file says that this device is already paired.
Probably if I delete the file, I can perform a new pairing.
Unfortunately, I have no idea where this file is located.

Can someone help me there?

Best thanks and greetings
Carlo

Which version of openHAB and webOS?

You properbly updates the firmware of your TV.

This happened to me and others, too.

If this is the same issue, you need to update openHAB to 3.4.2

1 Like

I use the latest OpenHAB V3.4.2 and my TV is a LG OLED65B7 with WebOS 3.5.

Ah ok, with a newer firmware of the tv you can’t pair as well?
I allready use the version 3.4.2. I also saw, there is a new option in the webos binding.
But I still can’t start a new pairing.

What happened before you suddenly started having this problem? Did you upgrade to openHAB 3.4.2? In this case you could try to disable useTLS in thing configuration.

No, but it’s possible that the TV updated his firmware byself.
The problem is, that I can’t pair anymore.
I can create a new thing with the ip-adress of the tv, but it never will pairing.
The “access key” field remains empty.

Update:

After more than 24 hours, the TV suddenly displayed a pairing request.
After confirming, an access key was written in the thing. so the device now seems to be paired.
I have no idea why it took so long to pair.

Unfortunately I still have a problem with the binding.
If I disabled TLS, the thing comes online briefly, but immediately goes offline again.
In the log file comes the message “error requesting channel list: 1010 tuner channel map does not exist.”

When I turn on TLS, the device never comes online.

Any ideas?

I found the problem.
It was an ip-address conflict… ( shame on me :wink: )
Anyway thanks for help!

1 Like

Hello! I have the same problem. I’ve already searched a lot on the internet and tried out a lot of instructions. I’ve been waiting for the pairing code for a year now… It’s a good thing that Christmas is coming soon and I’ve been wanting exactly this pairing code.

I’m currently running Openhab version 3.4.2 and have the LG OLED65G29LA. The firmware of the OLED is webOS 7.3.1-44.

The IP address is correctly stored in the thing. But as I said, the pairing hasn’t worked for a year.

Has anyone ever gotten an LG connected to the binding and can tell me why it no longer works?

I would really appreciate a correct way to do this.

Best regards
RedTiger

I have no solution for your issue, but I just want to confirm I have 2 LG TVs that connect to OpenHAB 4.1.0 (and now also 4.1.1). Some details of my setup:

I use configuration files for Things and Items and the .things file looks like this (I filled in IP and MAC address to allow the discovery and included the key later).

Thing lgwebos:WebOSTV:tvkitchen [host="10.20.1.237", key="abcabcabcabcabcabcabcabcabc123ab", macAddress="b0:37:95:dc:8a:b6", useTLS=true]
Thing lgwebos:WebOSTV:tvliving  [host="10.20.1.199", key="abc123abcabcabcabcabcabcabcacbab", macAddress="7c:64:6c:d6:a4:11", useTLS=true]

TV models: LG OLED65G3LA and OLED48A16LA.

Initially, the key is not used and the TV shows a popup asking if you want to allow a mobile device to connect (had to do it three times on one of the TVs). The tv Thing will come online and after that the key can be retrieved from the Karaf console and filled in. When using the UI and automated discovery, it should show up in the there.
This worked when I had the TV on and restarted OpenHAB.

openhab> openhab:things show lgwebos:WebOSTV:tvkitchen
UID: lgwebos:WebOSTV:tvkitchen
Type: lgwebos:WebOSTV
Label: WebOS TV
Status: OFFLINE: TV is off

Properties:
        lastConnected : 2024-01-10T20:36:22.906102727Z
        deviceOSVersion : 4.1.0
        deviceOS : webOS
        deviceId : 
        deviceOSReleaseVersion : 6.4.0

Configuration parameters:
        host : 10.20.1.237
        macAddress : b0:37:95:dc:8a:b6
        key : 31a8423f636d37c7d6e2e0dbea2759c7
        useTLS : true
  ...

The other TV:

openhab> openhab:things show lgwebos:WebOSTV:tvliving
UID: lgwebos:WebOSTV:tvliving
Type: lgwebos:WebOSTV
Label: WebOS TV
Status: OFFLINE: TV is off

Properties:
        lastConnected : 2024-01-10T22:41:24.987434071Z
        deviceOSVersion : 4.1.0
        deviceOS : webOS
        deviceId : 
        deviceOSReleaseVersion : 8.3.0
  ...

BTW, the TVs are in a different VLAN (and subnet) from OH (running on Kubernetes in a container/pod) but I do relay mDNS between them.