LG WebOS turning off but not on

, ,

Hi,

Who can help me?
I’m using the OpenHABian(2.4) on a pi and I’am using the LG WebOS binding https://www.openhab.org/addons/bindings/lgwebos/

I’m able to control most functions like volume, input source and turning off the tv, but turning on won’t work. I know that you should use the WOL binding https://www.openhab.org/addons/bindings/wol1/

So I configured a item for that…

WOL.items:

Switch Network_OpenhabWebsite “WOL tv woonkamer” (Status, Network) { wol=“192.168.0.255#78:5d:c8:1a:49:c0” }

When I turn on the switch this is the log:

2019-06-30 12:42:09.255 [INFO ] [nhab.binding.wol.internal.WolBinding] - Wake-on-LAN packet sent [broadcastIp=192.168.0.255, macaddress=785dc81a49c0]
==> /var/log/openhab2/events.log <==
2019-06-30 12:42:09.260 [vent.ItemStateChangedEvent] - Network_OpenhabWebsite changed from OFF to ON

But the tv isn’t turning on, who knows what I’m doing wrong? They are in the same network because I’m able to control the other function…

Is the TV configured to respond to WOL?

Well it’s a LG with the latest WebOS 2.x version.
So I don’t have the “Mobile TV On” option like WebOS 3 got.

Is there another option that I should enable in the settings to let it work?

No idea. Google throws up stuff like

Thanks for your help, I think that my tv doesn’t support WOL, I shall look into other solutions like IRTrans or HDMI CEC :wink:

Hi, I had issues getting my LG TV to turn on also, but there seems to be a bit of a weird thing happening on the TV and even though it is hard wired to the LAN I also need to enable the WOL for WiFi too in order to get it to work - Which it does now, without any issues.

My Rule:

rule "Power on TV via Wake on LAN"
when
Item LG_TV0_Power received command ON
then
    sendCommand( LG_TV0_WOL, ON)
    sendCommand( LG_TV0_WOL_WiFi, ON)
end

My Items:

Switch   LG_TV0_Power     "TV Power"      { autoupdate="false", channel="lgwebos:WebOSTV:bcfd8aa6-bf66-47ad-bda6-aabbccddeeff:power" }
Switch   LG_TV0_WOL                       { wol="192.168.100.255#AA-BB-CC-DD-EE-FF" }
Switch   LG_TV0_WOL_WiFi                  { wol="192.168.100.255#FF-EE-DD-CC-BB-AA" }

Note that the LAN and WiFi MAC addresses are different; This works for me - Hopefully it might help you.

1 Like

I guess that is about which network ports in the TV stay powered up when “off”. They need not behave the same way.

Thanks, I setup the items and rule the same as you have, when I check the logs I see that it sends the WOL signal to both MAC addresses but unfortunately the TV still won’t power on when I pull the switch…

Apparently it doesn’t seem to be possible with a LG 55EG9A7V…

I had the same problem with my LG 49SJ810V. My solution is similar to @dheneghan’s but I switched off the WiFi on the TV (in tv settings with LG remote) and only connect with LAN / UTP-cable because why need both? So I just need an item for the LG_TV_WOL. Make sure you set the MAC of the LAN-port in the item and not the Wifi-card’s.
Also consider the ip addresses, LAN might get a different one than WiFi.

What you could try is downloading a WOL utility for Windows (if that’s an OS you use) to send the magic packet, maybe to another machine on your network, see if it powers up. Or you could put a sniffer on your network to see if the magic packet is actually getting broadcast.

Hi there,

I have a similar issue and trying to figure it out. Do you keep both wifi and wired connected on the TV? Or just wired?

I’ve got no more issues. TV is on LAN, didn’t test on WLAN. Because I have subnet mask 255.255.0.0 i had to change the wol command to 192.168.255.255. first attempt was with the ip address of the tv, second was with the ending of ip to 255. But because I forgot the changed subnet I had to change last 2 segments of ip to 255.
192.168.178.60#xx:xx:xx:xx:xx - wrong
192.168.178.255#xx:xx:xx:xx:xx - wrong
192.168.255.255#xx:xx:xx:xx:xx - right

(Subnet mask 255.255.0.0)

Br3Ak3R,

Sorry for the late reply - glad to hear you have it working. For completeness: I’m on LAN only, have disabled the WLAN on the TV.