LGWebOS Binding (for LG WebOS TVs)

Tags: #<Tag:0x00007f618046be30> #<Tag:0x00007f618046bc28>

Can somebody help me?

It depends on what version of the binding you are running.
Until version 2.5.4 or 2.5.5, you can get the key by opening the configuration page of your thing in Paper UI.
In 2.5.5 or 2.5.6, this will be masked in Paper UI (for security purpose) but you have now a console command to show you the value of the key.
Sorry, I don’t remember if my change is already in 2.5.5 or not.
So first check in Paper UI and if masked use the console command.

Were you able to figure this out?

No, if I restart the openHAB service, the tv ask again: Do I want to connect? Like the first time.

I took the code and added a debug line to print the key and then after getting the key, went back to the current version.

Thanks, it is not enough pain to do that, but I will some day when I will have enough time.

Sorry, I missed your message. I have 2.5.5 but no accesskey in console.

openhab> lgwebos
Usage: smarthome:lgwebos <thingUID> applications - list applications
Usage: smarthome:lgwebos <thingUID> channels - list channels
openhab> smarthome:lgwebos lgwebos:WebOSTV:LGTV accesskey
Usage: smarthome:lgwebos <thingUID> applications - list applications
Usage: smarthome:lgwebos <thingUID> channels - list channels
openhab>

So just pair with your TV and check in Paper Ui the value of the key. Copy and paste this value in your config file. That’s all.

Nothing is there. The device id line is empty.

Enable the debug logs and show us your logs when pairing your TV.

Is your thing ONLINE after pairing?

Yes, it is online. I set debug logging, restart service and connect to tv again. Can you tell me a string what I can find in the debug log? It is huge.

Once paired and your OH has completed its startup, your command should spit out the accesskey. I went the route of recompiling the binding code and telling it to print the accesskey because I couldn’t get the command right. I tried your command in the console with my and it worked. If you can’t get it to work, I’d suggest you remove the binding, reload it, accept the discovered TV, accept the pairing on your TV, and then try the command again.

Did you open the configuration page of your thing in Paper UI to find your access key ?


Mine is masked because I use the most recent version of the binding.

Search for one of these logs (the log message evolved with the time and I don’t know which one is used in your version even if I guess it is the first):

  • store new key
  • Store XXXXX as access Key in the thing configuration
  • Store new access Key in the thing configuration

If this DEBUG log is in your log, that means that your thing configuration was updated. By the way, if your thing is ONLINE, that means that the thing configuration was updated.

OMG I’m so sorry I don’t know how I missed this. I didn’t click on the pencil icon just check the properties, shame on me and thank you.