Lightwave RF with OpenHab 2?

Tags: #<Tag:0x00007f746452b770>

Hi, Just started using the Openhab 2 platform as a way to control my home devices already linked through and working with Alexa. My wife doesn’t really get on with Alexa so the GUI on a tablet is perfect! I set up the Hue bulbs, and set up the TV on the GUI too. Can’t find much about Lightwave RF bindings though. Can it be done without having to write lots of code? Everything else has been simple to set up (Openhabian Pi image) so I’m hoping someone can help out.
Also anyway to switch multiple hue bulbs off with just one button on Habpanel would be good.

Many thanks! :smile:

http://docs.openhab.org/addons/bindings/lightwaverf1/readme.html

http://docs.openhab.org/configuration/items.html#groups

One thing missing from that section is any command sent to a Group gets forwarded to all members of that Group. So you would put the Group on your HABPanel.

Alternatively you can use a Proxy Item and a Rule to send the ON/OFF commands to all the bulbs.

Thanks rlkoshak. Does this work in openhab2? I couldn’t see the Lightwave RF listed add on in my instal pack. It is the standard instal package not the expert. Would I need to manually set up this add on using the instructions you linked to on my Pi?

Yes, it works, those links are to the 2.0 documents.

http://docs.openhab.org/tutorials/beginner/index.html

Thanks for your assistance Rich…

It seems I need the Basic UI package to access both the grouping and setting up the lightwave RF add on. But it would appear both basic and classic UI’s are not present on my install package. I’m looking for ways to add it. Documentation not been helping much so far.

This sentence is completely incorrect. BasicUI is just an end user interface. It has nothing at all to do with installing add-ons and only takes advantage of Groups but is not required for Groups.

You need PaperUI to install new addons. As explained in the Beginner’s Tutorial.

Please go back and follow the Beginner’s Tutorial step by step. It shows you how and explains the purpose for all the parts of OH and how they work together.

If you have to, reinstall OH 2 so you can choose the recommended “Standard” package when OH first starts up and you browse to its address for the very first time.

Then you will be able to install and configure most add-ons, including UIs using PaperUI, as explained in the Beginner’s Tutorial.

I think I’m having the same issues as Matt_Pocock.

I have read, re-read and re-read the documentation that rlkoshak links to but LightwaveRF does not show up in the addons page on OH 2 and therefore cannot be installed this way.

Hopefully I’ll work out a way to install it manually.

Hi, I too have just started playing with openHAB on Pi and want to control LightwaveRF devices via my LinkPlus (the gen2 version). I have installed all OK and have the PaperUI running but the LightwaveRF binding does not appear in the Bindinsg list. if i look on the OpenHAB tutorials pages the binding is listed. How do I get over this? I am very new to the Pi and i’m not a coder so struggling now to work out why the binding is not in my bindings list.

Any help would very much appreciated!!

+1

Can’t find it in the available bindings on a new install 2.4

I’m new to Openhab and just couldn’t figure out what I was doing wrong trying to add LightwaveRf, I’m kinda glad there is an actual issue and it not just me being an idiot!

Just wondered if any progress has been made?