Lightwaverf dimmer not working

hi all,

I have just installed a lightwaverf dimmer and wanted to add it to openhab, but seems that it does not work with the binding:

I added the following line:

Dimmer  Dimmer1 "Dimmer1 [%d %%]" (Ligths_Control)  {lightwaverf="room=1,device=6,type=DIMMER" }

But it does not do anything (the dimmer works from the lightwave app) just returns this error:

2015-10-04 17:40:06.195 [INFO ] [b.l.internal.LightwaveRFSender] - Ok message not received for 200,!R1D6FdP13

any suggestion why this might be?

Unless your item definition doesn’t have a typo from copying it is wrong, you need at least one space between the different parts like this:

Dimmer  Dimmer1 "Dimmer1 [%d %%]" (Ligths_Control) {lightwaverf="room=1,device=6,type=DIMMER" }

ah sorry, I have that (just copied in incorrectly). The declaration looks correct, as it shows up in interface.

On the current 1.7.0 binding those messages can be a false positive. Can you try the binding here and see if the logging is different?


Hi Neil,
The problem with this was that the ports in the setting were mixed up so
by default are the other way around.

I noticed the same thing, but can you test something for me.

With the ports switched you lose the ability to control the dimmer but the GUI should display the correct status for the dimmer when you operate manually, with the ports switched back you can control the dimmer from the GUI which also updates the GUI but does not update the GUI when the dimmer is operated manually.

Also, do you have the dimming function working or just on and off?

that’s interesting, I will test that this evening.

If the ports are correct, the dimming function works ok from the GUI.

I tried lightwaverf binding version 1.8.0 but the situation for me is still the same. I am unable to dim any of the dimmers from the OH GUI, do I need a rule?

i just have these two items, no rule:

Dimmer Light_LR_D "Dimmer1 [%d %%]" (Ligths_Control) {lightwaverf="room=1,device=3,type=DIMMER" } Switch Light_LR "Switch1" (Ligths_Control, Lights_LR) {lightwaverf="room=1,device=3,type=SWITCH" }

Strange, that is basically what I have except I don’t have separate switch items, I just click once up/down for on/off and I include the graphic slider :-

Dimmer LW_Dimmer_1G1  "Dimmer1 [%d %%]" <slider> (LW_LW400Dimmer) {lightwaverf="room=2,device=1,type=DIMMER"}

My lightwave logging shows this when trying to dim but nothing happens :-

2015-11-12 23:50:13.283 [DEBUG] [.l.internal.LightwaveRfBinding:249 ]- internalReceiveCommand(LW_Dimmer_1G1,DECREASE) is called!
2015-11-12 23:50:13.493 [DEBUG] [.l.internal.LightwaveRfBinding:249 ]- internalReceiveCommand(LW_Dimmer_1G1,DECREASE) is called!
2015-11-12 23:50:13.703 [DEBUG] [.l.internal.LightwaveRfBinding:249 ]- internalReceiveCommand(LW_Dimmer_1G1,DECREASE) is called!
2015-11-12 23:50:13.913 [DEBUG] [.l.internal.LightwaveRfBinding:249 ]- internalReceiveCommand(LW_Dimmer_1G1,DECREASE) is called!
2015-11-12 23:50:14.124 [DEBUG] [.l.internal.LightwaveRfBinding:249 ]- internalReceiveCommand(LW_Dimmer_1G1,DECREASE) is called!
2015-11-12 23:50:14.333 [DEBUG] [.l.internal.LightwaveRfBinding:249 ]- internalReceiveCommand(LW_Dimmer_1G1,DECREASE) is called!
2015-11-12 23:50:14.543 [DEBUG] [.l.internal.LightwaveRfBinding:249 ]- internalReceiveCommand(LW_Dimmer_1G1,DECREASE) is called!
2015-11-12 23:50:14.753 [DEBUG] [.l.internal.LightwaveRfBinding:249 ]- internalReceiveCommand(LW_Dimmer_1G1,DECREASE) is called!

Any chance someone can post their lightwave log when dimming from OH is working, I think I should see a “Sending Command[**********]” which looks to be missing.

sure, it’s actually sending a value as follows:

2015-11-13 00:53:57.188 [INFO ] [runtime.busevents ] - Light_LR_D received command 94
2015-11-13 00:54:02.057 [INFO ] [runtime.busevents ] - Light_LR_D received command 96

Very odd, I just get a command that says DECREASE instead of the actual command :-

2015-11-13 01:00:10.101 [INFO ] [runtime.busevents             ] - LW_Dimmer_1G1 received command DECREASE
2015-11-13 01:00:10.311 [INFO ] [runtime.busevents             ] - LW_Dimmer_1G1 received command DECREASE
2015-11-13 01:00:10.520 [INFO ] [runtime.busevents             ] - LW_Dimmer_1G1 received command DECREASE

Ah, I think you must be trying this from the iOS app, and I’m on Android (different interface I believe).

Looks like not mapped correctly.

I have progress, well sort of.

I just tried it from the iOS app and its working, its the desktop / web based GUI that is broken.

In the iOS app dimmers have a slider and I can drag to any position and it works, although I have the same issue that others have reported with zero jumping to fully on.

The desktop / web based GUI has icons for up / down on dimmers and these are not working.

Hi. Can you describe the exact steps and what you are seeing for 0 jumping to fully on?

Are the steps being run in the Lightwave App or the Openhab App?


Works fine in the official Lightwave App, goes full brightness from Openhab App, both running on iOS.

Hey - see here for an update: LighwaveRF dimming not quite right

Another update and a release here: LightwaveRF Binding Updated