LighwaveRF dimming not quite right

Hi wondering if someone can help.

I’ve got some lightwaverf dimmer switches which do work in openhab, however dimming right down (where I would expect it to turn the light off) sends the light to full brightness. I assume its sending dimm = 0 which isnt recognised by the hub or something.

Ive got round it by addinig a switch and dimmer statment for each light e.g.

Switch Light_GF_Lounge_Ceiling          "Lounge Ceiling"                (gGF, Lights)   { lightwaverf="room=3,device=2,type=SWITCH" }
Dimmer Light_GF_Lounge_Ceiling_D        "Lounge Ceiling [%d %%]"        (gGF, Lights)   { lightwaverf="room=3,device=2,type=DIMMER" }

Am I doing something wrong or is this a bug?

thank you


Do you have any logs from the lightwave binding?

I am seeing the exact same. It’s sending !R1D1P0 and light is going to full brightness


Are you able to confirm what the lightwave app sends when you hit the off button in the app? I.e. can you see the lightwave command using wireshark or similar?

Not sure if its any help but that doesnt look like any of the commands I was using when testing with netcat, the first two are to turn the dimmer on / off, the others are dimming commands :-

echo -ne "226,!R2D1F1" | nc -u 9760
echo -ne "226,!R2D1F0" | nc -u 9760
echo -ne "226,!R2D1FdP1" | nc -u 9760
echo -ne "226,!R2D1FdP31" | nc -u 9760
echo -ne "226,!R2D1FdP1" | nc -u 9760
echo -ne "226,!R2D1FdP31" | nc -u 9760

Thanks I think I’ve found the problem and it is fixed in my repo here:

If you are happy to compile it yourself.

I’ve still not managed to fix the issue with the send/receive ports.

Great work Neil, thanks.

I don’t have an environment setup to compile myself so happy to wait for the next release.

What are your thoughts on the send / receive port issue?

thanks for sorting that, also don’t have an environment but I can wait.

Send/Receive is still causing me issues - I can’t seem to get it to work. I’m also waiting for the EnergyMonitor pull request to be merged into the main repo before before moving on much more. As I’m not a git expert and keep getting myself in wormholes when doing multiple things at once!

I’ve created a release here to fix dimming:

Let me know how it works it does also include some work for fixing the send/receive so let me know any feedback on that as well.

Hey Neil,

Sadly that release does not work for me, I have no control over the dimmers not even to switch on / off, I also tried swapping the ports over in the openhab.cfg but still no control.

Anyone else had chance to try it?

Yeah I’ve been trying it out too. My WiFi Link has stopped responding to openHAB again.

I’d decided I was going to do a complete reset on the WiFi Link as it seemed to have muddled up some of the devices. So I did that this afternoon and then reset each dimmer/switch and re-paired it with the Link via their brand new iPhone app. So that’s all working as it should now (I did have a few plug in switches that wouldn’t reset, so I’ve pulled them out).

The WiFi Link did ask to confirm a new registration, but now isn’t responding again. I’ve even tried the manual pairing technique, which hasn’t worked either:

> echo -ne '001,!F*p|' | nc -w1 -u 192.168.x.xx 9760

So now I’ve reverted to the 1.7.0 version of the binding, to see if I can get it back again.



I’ve fixed the issue in the new release (sorry I don’t actually use the binding to send commands as I have an RFXCOM).

The fix along with lots of other changes are here documented here: LightwaveRF Binding Updated


just to say got 1.8.0 installed and the lightwave dimming is all working just a treat now thank you very much.

1 Like

I have followed the instructions for lightwaverf binding 1.12 with OH 2.2.0 appears to be registered and working from the logs, i am needing examples
of where to go next, most excellent information on this forum