Linear Garage Control Z wave - How to make it work?

I tried to install this today with no luck.

After pairing it with my Aeon Labs Z Wave Usb Stick. My habmin did not find it.

Has anyone managed to make this work with Openhab? If so can you please point me in the right direction?

Thank you.


1 Like


I have the same device and could never get it to work with OH nor Openzwave. It uses the Motorized Barrier Command Class which is not supported by either platform.

I am in the process of migrating to a Vera with the MIOS binding. According to the docs, the device is supported. I have seen the device support in the web server. I just haven’t had the time to pair them (location and distance issues). The Vera is an ok device, but I would love to go back to my USB stick and OH.

The Openzwave guys have an opener now and should write the CC fairly shortly. It could then be ported to OH.

– Kevin


Thanks for letting me know. I am going to wait for a solution then. Hopefully it will be in Openhab soon. Please if you get the news before i do share :slight_smile:

Have a great week.

I am also interested in seeing this come to fruition as well. I just picked one of these units up with intent to use in an openhab build so I also appreciate any efforts made.

I saw these for sale for $35 at my local Lowes (Austin, TX)

It’s their Iris version, but think is basically the same.

Anyone get one working?

New to the community… jumping in with both feet (at times too quickly).

I made some bad assumptions about this device and purchased it without realizing it was not going to work.

Sounds like the openzwave folks have some progress in getting it too work. I am not sure if/when/how hard it would be to port that over to openHAB.

Trying to decide if I want to return the GoControl and get a MyQ? or hold out for the zwave support?

Any thoughts?

I got a Vera Plus Z wave controller instead. If you go the MyQ route it
would probably end up costing you a little less. But the Vera plus Z wave
controller is very versatile.Let’s you connect different technologies,
awesome support so far and getting my devices working with it has been a

Good luck

@ruyaguilar Thanks for the reply.

Just curious… did you move all your Z-Wave devices over to the vera plus? Did you lose/gain any flexibility with the zwave items using the vera plus and MiOS binding vs. the Zwave binding?

Soo many choices… I like it :slight_smile:

@smak01 Have not tried the binding yet. Before I try it I want to have all
my devices added to the Vera controller. I have some devices I have not
installed yet. I have trouble installing my way switches. I seem to be
missing a neutral cable to make the add-on switches work. Let me know if
you have any ideas.
I have avoided having to call the electrician for this and have been busy
to give it another try at fixing this.

Will let you know once I try the binding. But so far stock works. I had
another unexpected advantage of getting the vera plus. I have an Ademco
VIsta system with and envisalink module. No openhab binding for envisalink
not sure why. There is an add-on app for the vera to connect to the
envisalink. Which essentially means that know I can create scenes that can
be triggered with my door and window sensors :slight_smile:

Love the vera plus so far.

I did move all my devices over to the Vera, but I would eventually like to move them back.

For now, I have the following working with Vera/Mios

– Standard switches/dimmers/outlets (GE / Leviton)
– Kwikset Lock
– GD00Z-4 Garage Opener

@ruyaguilar and @gottsman thanks for the input. I think I will try out the Vera/MiOS solution for the near/mid-term until the security pieces of the zwave binding are more fleshed out.

anyone has any idea how to make it work
thank you

I believe the device should work, so you might want to provide some information on what problem you’re having, what system are you using (versions etc)…

I’d like to start by saying I’m extremely new to the community, so please excuse my ignorance. Has anyone had luck getting the gdz00-4 to report back anything? I’m using pi2 with zstick and was able to successfully add the gdz00-4 as a thing through the Paper UI, but once adding the “barrier state” and “alarm (raw)” as items they haven’t updated with anything. Currently showing “-NaN” for barrier state and nothing for alarm. I’ve replaced the sensor batteries and re-added the gdz00-4. Any ideas?

Having same issue. I just got mine securely paired, but I also just see alarm raw and barrier_state with no updates.

Anyone figure this out by chance?