Linear HUSBZB-1 in linux

  • Platform information:

    • Hardware: _CPU i3/RAM 8 g/storage 1tb
    • OS: Debian 9
    • Java Runtime Environment: _openjdk
    • openHAB version: latest stable
  • Issue of the topic: I have a Linear HUSBZB-1, it worked in OpenHAB running in Windows but I can’t get it to work in debian

  • Detailed explanation: I had openHAB running on a Windows 8.1 desktop. Purchased and installed HUSBZ-1 with windows driver. Installed binding in paperUI, discovery found both controllers. com3 and com4. Next discovery found two motion sensors iris and smartthings. I was so delighted, I purchased a dedicated pc to run openHAB on. I have linux experience, mostly CentOS, fedora, RedHat but have run Ubuntu and installed Debian. Up and running, installed openHAB via openhabian docs.
    I’m almost certain this is something I’m just not getting in either the operating system configuration or my java configuration because I’m rusty with linux.

  • Things I have tried:

    • Install Chris’s great binding in paperUI
    • add openhab user to tty and dialup
    • edit /etc/default/openhab2 to add EXTRA_JAVA_OPTS=""
    • run lsusb
    • run dmesg | grep tty
    • restart system & openHAB
  • Errors and logs:

    • in paperUI things
Status: OFFLINE Failed to initialize ZigBee transport layer
Status: OFFLINE - COMMUNICATION_ERROR Serial Error: Port /dev/ttyUSB0 does not exist
  • chunk of log
2018-10-21 14:57:10.251 [ERROR] [ding.zigbee.handler.ZigBeeSerialPort] - Serial Error: Port /dev/ttyUSB1 does not exist.
2018-10-21 14:57:10.252 [ERROR] [zigbee.dongle.ember.ZigBeeDongleEzsp] - Unable to open Ember serial port
2018-10-21 14:57:22.305 [ERROR] [ding.zigbee.handler.ZigBeeSerialPort] - Serial Error: Port /dev/ttyUSB1 does not exist.
2018-10-21 14:57:22.306 [ERROR] [zigbee.dongle.ember.ZigBeeDongleEzsp] - Unable to open Ember serial port
2018-10-21 14:57:45.932 [ERROR] [ding.zigbee.handler.ZigBeeSerialPort] - Serial Error: Port /dev/ttyUSB1 does not exist.
2018-10-21 14:57:45.932 [ERROR] [zigbee.dongle.ember.ZigBeeDongleEzsp] - Unable to open Ember serial port
2018-10-21 14:58:57.968 [INFO ] [ing.zwave.handler.ZWaveSerialHandler] - Connecting to serial port '/dev/ttyUSB0'

thanks for any help

got it up and running… yes!
the cure? added the serial binding. Did not have to do that for Windows version and for that matter don’t recall a ‘serial’ binding. Anyhow, also restarted system and openHAB before seeing signs of success. PaperUI opened with two zigbee motion sensors in the inbox & both controllers z-wave and zigbee online
Thank you Chris Jackson for these terrific bindings. Anybody want to buy a hue or smartthings hub?
For the record Linear HUSBZ-1 works great in Windows and Linux

edit to add link to thread where serial binding hint made in post 7

I know this is an old thread, but:

  1. gratitude never expires! Lol.
  2. I am willing to bet that you and I are not the only folks that have run into issues with this setup, so this will refresh this post…

I had a similar situation, in that I had everything running wonderfully with the HuSBSBZ-1 on a RPi3. Recently inherited a Poweredge R210ii, threw Ubuntu on it, and am working on converting it to my Home Automation central server (was playing with Snips, nor Rhasspy, so the raw power versus a Pi is nice to have)…but couldnt bring the controller up…in my case, I had forgotten to add openhab to the tty group, but this is a great checklist for all to review if having issues with any flavor of the HUSBSBZ1 and Linux…

Thanks for the help!