Link between Things and Items

Hi all,

I moved from 2.5.4. to 3.0 as I couldn’t install the zwave binding in 2.5.4.
I copied all my configuration files from 2.5.4 to 3.0, but I think 3.0 is dealing different with the configuration files than 2.5.4.

What is new in 3.0 is creating the link between a thing and an item (I haven’t seen this in 2.5.4, although this might have been in the background and now it is more visible).
I get an error there which states: (unknown) Invalid Link.

I’m not sure if it is relevant, but I run the following config:
openHAB 3.0
Ubuntu Server 21.04

My lights.things:

Bridge milight:bridgeV6:F0FE6B62C62A [ host="", bridgeid="F0FE6B62C62A", passwordByte1=0, passwordByte2=0, repeat=2, delayTime=75 ] {
    Thing rgbwwled all "All Lights" [ zone="0" ]
    Thing rgbwwled living_room "Living Room" [ zone="1" ]
    Thing rgbwwled bedroom "Bedroom" [ zone="2" ]
    Thing rgbwwled office "Office" [ zone="3" ]
    Thing rgbwwled bathroom "Bathroom" [ zone="4" ]

My lamps.items:

// Switches to control zone 3 (office)
Switch office "Office" {channel="milight:rgbwwled:F0FE6B62C62A:all:3:ledbrightness"}
Switch office_nightmode "Night Mode: Office" {channel="milight:rgbwwled:F0FE6B62C62A:office:3:lednightmode"}
Switch office_whitemode "White Mode: Office" {channel="milight:rgbwwled:F0FE6B62C62A:office:3:ledwhitemode", homekit="Lighting"}
Dimmer office_brightness "Brightness: Office" {channel="milight:rgbwwled:F0FE6B62C62A:office:3:ledbrightness"}
Color office_color "Color: Office" {channel="milight:rgbwwled:F0FE6B62C62A:office:3:ledcolor"}
Dimmer office_speed "Animation Speed: Office" {channel="milight:rgbwwled:F0FE6B62C62A:office:3:animation_speed_relative"}
Number office_mode "Animation Mode: Office" {channel="milight:rgbwwled:F0FE6B62C62A:office:3:animation_mode"}
Dimmer office_mode_relative "Animation Mode Relative: Office" {channel="milight:rgbwwled:F0FE6B62C62A:office:3:animation_mode_relative"}

I would appreciate if someone could review the above and in case there are mistakes, point me in the right direction.

Thanks in advance!

The binding docs do not show the channel UID this way at all, they only use the zone number and not the Thing name.

It’s possible it works with the name as alternative, but not both I think.

Thanks Rossko! It was part of the solution. It turned out that thing is also case sensitive. So instead of rgbwwled, it should be rgbwwLed (capital L). Now it works! :slight_smile: