Linking a textual Item to a Channel in OH3

I just upgraded to OH3 earlier today. I decided to do a fresh install to get rid of all the junk that cluttered up in the past, but I decided to copy over some .items and .thing files that I want to continue using. All of those Items and Things show up in the UI just fine.
In my previous OH2 setup, I had some UI-defined Things whenever autodiscovery was available, but all other Things and all of my Items came from text files. I would then link these items to channels via Paper UI.

I tried the same approach again, but I can’t seem to link my textually defined items to channels in OH3. I navigated to Things > [some Thing] > Channels > [some Channel] > Add Link to Item, selected Use existing Item and clicked Item to link, only UI-defined Items show up in the list. All textually defined Items are missing. However, all of them are there when I click on Items on the left sidebar.

Of course, I double-checked that both the channel and the Item I’m trying to link have the same type (Switch in this case). But that probably doesn’t matter anyway because I can link all the Locations and Equipments I created just fine. (Are there even any scenarios were that makes sense?)

I created an additional Switch type Item in the UI for testing and I can link that just fine, but I’d rather keep using my item files. Also it doesn’t seem to matter where the Thing in question was defined. I also tried multiple Things and Channels, but text-based Items didn’t show up once.

So is this a bug or am I missing anything? Thanks!

EDIT: I ended up using the opportunity to define my links in the text files as well. That works without any issues so far and those links are even shown in the UI. But I’d still like to know what’s going on here, and if this is a bug, this really needs to be fixed.

The problem starts when mixing file-based setup with UI-based. The suggestion is to NOT do it.

I never had any issues at all doing that in OH2. But whatever, I prefer file-based anyway most of the time. I just hope that having some autodiscovered Things in there doesn’t cause any problems down the road.


I’m facing the same issue after migration from OH2 to 3.

All my items, rules and sitemap are defined in files and versioned using git since I started with OH1. Things however are all created using UI because creating them using files is a mess in my opinion and auto-discovery is not possible.

For me this was a very usable solution until now and worked like a charm in OH2.

So the main question for that is whether it is a bug or a feature that linking items from files is not working anymore.

If it is a feature I have to admit that it is not the best one of OH3 and need to find a solution.

From my perspective it is even more worse!

I have all items linked to channels in OH2.5 with text files, which worked like charm and thanks to my file structure, it was well organized.

Now I fight since some days, to get the items in OH3 - I decided to have a fresh installation.
Either I add items per textual definition or by items-file, it misses the link to the channels.

Example OH2 items file:

Number EG_hwr_ht_tuer_act_temp “Ist Temperatur HWR [%1$.1f °C]” (gEG_hwr,gEG_hwr_thermostat,gEG_Temperature) [“CurrentTemperature”] {channel=“homematic:HG-HM-CC-RT-DN:35ef1fcb:ABCSDDSE:4#ACTUAL_TEMPERATURE”}

Result in OH3:

I have to re-add them one by one by UI - I have more then 800 items! It would be a pure disaster!

Maybe I do something wrong here, but I don’t have the impression.

Honestly, I was that enthusiastic, when I read but OH3 in Dec. But, now after more then 4 weeks, I get more and more frustrated, as the basics does not work (i.e. try to move an item via the Symantec Model, which is impossible - I normally would expect, that I could do it with a mouse click).

If I have to re-add all items to things by UI, I will give up with OH3 and start to consider a full new start with our smart home software.

You seem to be describing a different problem. I recommend you create your own thread for that.

That being said, your Items file looks fine to me. Have you made sure that the Channel and the Thing actually exist? You said that you started from scratch, so it might have gotten a different ID, or maybe you just forgot to add it. I recently had problems with the Astro trigger channels but it turned out I had simply forgotten to add the local sun as a Thing.