Linking previously linked Insteon LED Bulb to hub?

I’m making progress in my openHAB/Insteon setup. All of my devices except an LED bulb are linked and responding. It is already linked to an Insteon hub, but I want to link it to my PLM so I can remove the hub from my system. I removed the LED bulb, pressed the set button on the PLM until it beeped, and then reinstalled the bulb. The PLM beeped twice when I did this, so I thought it was linked. I restarted openHAB and got this in the log.

device xx.xx.xx found in the modem database, but is not configured as an item…

It still responds to the hub commands but openHAB can’t control it.

I’ve looked online and can’t find any info on how to fix it. Any ideas?


Did you add the xx.xx.xx as an item in any *.items file? Insteon is a 1.x binding, there’s no discovery. Adding to the plm is step 1, adding it as an item is step 2.

Yes, I have the item in my items file. I tried to link the bulb to my PLM and then I restarted openHAB to reread the items file. The log shows that it is on the list but not linked. I’m trying to figure out how to link the LED bulb to the PLM. The manual from Insteon doesn’t help - I’ve tried twice to remove the bulb, start the linking action on the hub, and reinstall the bulb with no success.


Can you post your items file (maybe this one and one that is working) along with whatever is showing up in the logs?

Also may be helpful to know the which kind of device is it? Dimmable bulb - which model number?

I don’t have any bulbs but I’ve had the Insteon usb plm set up in OH for a while now with dimmers, switches, and one open/close module.

Leave the lamp on, unload the binding if OH is running, put the PLM in linking mode, unscrew the light bulb, wait about 3 seconds, screw it back in. See if that works. (and unplug the hub before all that).

Thanks, I’ll give it a try!

So I unplugged the hub,
unscrewed the LED bulb,
pressed the link button on the PLM
screwed the bulb back in,
I heard the PLM beep,
unscrewed the bulb and put it back outside.
I don’t see any errors in the log, but the light doesn’t respond. Here’s an excerpt from the log:

2018-12-24 19:42:46.747 [ome.event.ItemCommandEvent] - Item ‘porch’ received command OFF

2018-12-24 19:42:46.838 [vent.ItemStateChangedEvent] - porch changed from ON to OFF

2018-12-24 19:42:48.525 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - Item: porch got command ON

2018-12-24 19:42:48.563 [ome.event.ItemCommandEvent] - Item ‘porch’ received command ON

2018-12-24 19:42:48.652 [vent.ItemStateChangedEvent] - porch changed from OFF to ON

I’m also seeing this:

2018-12-24 19:48:55.232 [INFO ] [g.insteonplm.InsteonPLMActiveBinding] - devices: 13 configured, 12 polling, msgs received: 21

Any idea what I need to do?


So the key piece was to delete the LED bulb from the Insteon app. Once I did that (and turned off the hub) I got an error message saying that the LED bulb was not a switch. I changed my .items entry to call it a dimmer and now it responds to openhab!