Links on openHAB website do not work

I have already created an issue for a problem on the documentation website:

There is the same problem on the main website, e.g. on the links in the top bar (e.g. “Download” are not working. The console shows these error messages:

@Confectrician @Kai

BTW: What do you think of creating an own category for the website here in the forum?

If you mean this, it works for me.

Yes, I have tested it in three browsers and two different operating system. Always the same error messages.

I have now tested it with a browser outside of my network. This worked. Maybe a problem with a DNS Server.

1 Like

the download page still does not work here.
Maybe it is a cloud-flare related problem and it is region dependent.

I agree. I also think that it could be Cloudflare’s fault. But it is not really region-specific.

I have restarted my router and I have some strange results. On my Windows machine it does not work in Chrome and Edge but it works in Firefox. All browsers are trying to load the files from the same IPv6 address. In a VM on the same machine it does not work in Firefox.

On another machine Linux machine it works in Chrome.

I have connected via VPN to a Windows server in my company and there it works. It is also in Germany but uses a different Telekom network.

I am IPv4 only thanks to my ISP :frowning:

II don’t think that the problem is related to IPv6. In Firefox in Windows I am using also IPv6 and it works.

I have also disabled IPv6 but the same result with IPv4 only.

Really a bit strange.

From that what I see it looks similar to the behavior a few days before. At that time Kai did a rebuild of the cloudflare cache: next.OpenHab (Website) problem

@Bruce_Osborne Did you use https or http? If I use http (which is only possible in Firefox) it works. With https it also fails in Firefox.

https. Chrome, Windows

Then I would assume that it is Cloudflare problem and maybe region-specific.

Virginia, Eastern US here.

So it seems to be a problem in Germany or maybe Europe.

There are also problems with loading some of the docs:

Here in the UK (Europe for another 24 hours…) the website is fully functional…

(Brave browser on Android on WiFi via https, if that helps)

1 Like

We are all with you :slight_smile:

Can also confirm problem with downloads and doc here in Germany

Then I would assume that it is Cloudflare problem and maybe region-specific.

Seems to be, yes. I purged the cache and it seems to have solved the issue.

1 Like

In case this happens again is there any preferred way to report this kind of problem or a person / account it should be addressed to ?

We have a dedicated GitHub Repository for the website:

@MHerbst opened an issue in the docs repository which should work too usually

I think there were also reports via mail yesterday.

1 Like