LIRC binding problem on raspbian stretch - connection refused

Hello there,
I have successfully installed LIRC on raspbian stretch and can manually send IR-commands over the console with:
irsend SEND_ONCE ledband_werkstatt KEY_POWER

The binding is configured like this:
Bridge lirc:bridge:local [ host=“”, port=“8700” ] {
Thing remote ledband_werkstatt [ remote=“ledband_werkstatt” ]

The lirc_options.conf file has the same address and port, so it should work. In the logfile of openhab I see this message:

2018-01-30 16:26:22.910 [ERROR] [nding.lirc.handler.LIRCBridgeHandler] - Connection to LIRC failed Connection refused (Connection refused)
at Method) ~[?:?]
at [?:?]
at [?:?]
at [?:?]
at [?:?]

Anybody knows how I could solve this problem?


Hi @Mr_Luz !

I have the same issue with latest snapshot, did you solve your problem?

2018-03-31 21:17:50.828 [ERROR] [nding.lirc.handler.LIRCBridgeHandler] - Connection to LIRC failed Connection refused (Connection refused)
at Method) ~[?:?]
at [?:?]
at [?:?]
at [?:?]
at [?:?]
at [?:?]
at [?:?]
at [?:?]
at [?:?]
at org.eclipse.smarthome.binding.lirc.internal.connector.LIRCConnector.connect( [216:org.eclipse.smarthome.binding.lirc:]
at org.eclipse.smarthome.binding.lirc.handler.LIRCBridgeHandler.connect( [216:org.eclipse.smarthome.binding.lirc:]
at org.eclipse.smarthome.binding.lirc.handler.LIRCBridgeHandler.access$4( [216:org.eclipse.smarthome.binding.lirc:]
at org.eclipse.smarthome.binding.lirc.handler.LIRCBridgeHandler$ [216:org.eclipse.smarthome.binding.lirc:]
at java.util.concurrent.Executors$ [?:?]
at java.util.concurrent.FutureTask.runAndReset( [?:?]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301( [?:?]
at java.util.concurrent.ScheduledThreadPoolExecutor$ [?:?]
at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:?]
at java.util.concurrent.ThreadPoolExecutor$ [?:?]
at [?:?]

I had the same issue on Stretch, after following this guide to setup lirc.

It turns out that even though the option “–listen” is included in LIRCD_ARGS in configuration, the service was not really listening on any port. I confirmed using:
sudo netstat -peanut | grep 8765

So I edited /etc/lirc/lirc_options.conf and edited/commented out:
listen =
(which is what I had in my LIRC bridge configuration)

After restarting lirc (sudo /etc/init.d/lircd restart) netstat showed the service bound on 8765.
So, after also restarting openHAB, the bridge went online!

@HALLO01, @Mr_Luz
I just noticed that the default behavior of the forum is to “track” threads instead of “watch”, which means you guys won’t be notified if I don’t reply to you specifically, hence the edit. Although a long time has gone by, I’m sure you’ve found the solution by now! This is more for anyone googling the same problem.