Local URL not working sometimes

Hi !

Since some update (iOS and openhab update) I can sometimes not connect to the local URL getting a 404 error. After a day or so it works again. I don’t see anything in the openhab.log.

my url is in the iOS client config and if I enter the URL in the browser I can reach the app.

any help on this ?

Are you sure that your iPhone is on your wifi when you get the 404?


if I use the safari browser on the mobile I see the interface

I’ve seen similar behavior sometimes if I have had the iOS app open outside my LAN (remote URL via myOpenHAB) and then try to access OH from my LAN. Closing the app and restarting it usually fixes the problem so it may be an issue with the iOS app state when transitioning between local and remote URLs.

already tried that by force closing the app but I still get the error

I restarted openhab now and I can connect again with the ios client.
I still dont understand why I can connect with the browser but not with the
app (and that a restart solved it doesnt make sense)

For visibility to others reading this in the future, make sure you disable IPv6 in your OS. OH binds to IPv6 first and will cause issues. My issue was my ios app wouldn’t connect at all, I browsed the service discovery and noticed it was sending me OH’s ipv6 IP which my phone couldn’t connect to as I wasn’t running ipv6 at the time. Disabled IPv6 in the OS and haven’t had another issue connecting remotely or locally since.

1 Like

thx for the hint. will try that.

yours Arnold

I tried as Jay suggested but it still doesn’t work for me. IPV6 is now
disabled on my Ubuntu box but the iOS client still cannot connect once in a
while (Safari on the mobile and Safari on my Mac can connect). Any other
ideas what could be wrong ?

Btw. I also tried it now on my wifes Android phone and I also get the same
issue that once in a while the native client app doesn’t connect anymore
till I restart openhab :frowning: