Localhost:8080 - Connection refused

Out of the blue, I am no longer able to connect. Using RPi3. I checked the openhab2 file in /etc/default and the html_port is commented out. I specifically set it to 8080 and still no smiles. I ran “sudo systemctl status openhab2.service” and got this error message.
root@DietPi:~# sudo systemctl status openhab2.service
● openhab2.service - openHAB 2 - empowering the smart home
Loaded: loaded (/usr/lib/systemd/system/openhab2.service; enabled; vendor pre
set: enabled)
Active: activating (auto-restart) (Result: exit-code) since Sun 2019-08-04 10
:31:26 EDT; 3s ago
Docs: https://www.openhab.org/docs/
Process: 16045 ExecStop=/usr/share/openhab2/runtime/bin/karaf stop (co
de=exited, status=1/FAILURE)
Process: 15934 ExecStart=/usr/share/openhab2/runtime/bin/karaf $OPENHAB_STARTM
ODE (code=exited, status=1/FAILURE)
Main PID: 15934 (code=exited, status=1/FAILURE)

Aug 04 10:31:26 DietPi systemd[1]: openhab2.service: Control process exi
ted, code=exited status=1
Aug 04 10:31:26 DietPi systemd[1]: openhab2.service: Unit entered failed
Aug 04 10:31:26 DietPi systemd[1]: openhab2.service: Failed with result

Any suggestions would be most appreciated.

Hi Steve
Try restarting the PI

I tried reboot without success and also unplugged the RPi but no go.

Next guess would be an SD-card corruption…if that is the case, take a new SD-card and re-install your system from scratch. Hope you are having backups.
If not, as you can still ssh into your raspberry, maybe run openhab-cli backup get the zip file of the raspberry and hope that nothing was corrupted…

Ok, this is getting weird. I decided to load OH2 on to my Ubuntu 18.04 laptop using the repository. Tried to open OH2 with localhost:8080 and got a refusal
and the “sudo systemctl status openhab2.service” produced the same message as before.
Two different computers, same result. I was able to get it running on Windows 10 (same computer with dual boot) but I hate Windows and only use it for non-Linux friendly programs. I really want to get OH2 running again on the RPi.
I think I am going to take a nap.

It was a good nap. Went back and started OH2 using /.start.sh (I had been using sudo systemctl start openhab2.service) and bingo, I’m back in business. However “sudo systemctl status openhab2.service” still generates an error message – whatever.